[OBSOLETE] Tado (Connect)

I have just purchased a Tado thermostat and tried add the Smartthings device handlers & smartapp.
Went through the setup in the smart app but kept getting an error message at the last step that I couldn’t complete the setup process. Any idea why I’m getting an error?

Please goto the IDE Live Logging and PM me your logs.

I should be able to figure it out very quickly for you.


Stuart Buchanan

Hi Stuart, I couldn’t PM you as it says your page is private. Can you drop me a line to my inbox so that I can reply you? Thanks.

Hi Stuart, amazing work creating Tado Connect for Smartthings!

I’m trying to get Smartthings to put hot water into manual mode and switch it on, when a Smartthings presence sensor keyring is detected, then put Hot water back into normal schedule mode when the sensor leaves (so I can give the ST keyring to a cleaner, so she doesn’t have to have the tado app installed on her phone).

I followed your great, clear instructions and the tado connect app appeared no problems. Having configured it, I can see the hot water Thing. But the only buttons which work are “Off” which takes it out of Home mode and puts it into Manual mode. And “End Manual” which allows it to go back to Home mode.

I can not switch the hot water On once it is in manual mode. The Emergency Heat, and Heat buttons have no effect. Both sets of up down arrows have no effect, and only the outside temp reading works.

The Heating Thing works just fine, shows all the temperatures, lets me set them and the boiler kicks in.

Am I missing something about the hot water? how do I switch it on?

My boiler only has On/Off for hot water, it does not allow tado to set a particular water temp. My schedule has the hot water off for most of the day even when people are home.

Looking at the logs, it appears that for Hot Water, both the Heat button and the Off button send “power:OFF, type:HOT_WTER”:

Executing parseResponse: [setting:[power:OFF, type:HOT_WATER, temperature:null], preparation:null, overlay:null, openWindow:null, link:[state:ONLINE], activityDataPoints:[:], overlayType:null, tadoMode:HOME, geolocationOverride:false, sensorDataPoints:[:], geolocationOverrideDisableTime:null]

Whereas, if I set the Hot Water On using the Tado app, then refresh in Tado Connect, I see “power:ON, type:HOT_WATER”:

Executing parseResponse: [setting:[power:ON, type:HOT_WATER, temperature:null], preparation:null, overlay:[termination:[projectedExpiry:2017-06-09T05:30:00Z, type:TADO_MODE], setting:[power:ON, type:HOT_WATER, temperature:null], type:MANUAL], openWindow:null, link:[state:ONLINE], activityDataPoints:[:], overlayType:MANUAL, tadoMode:HOME, geolocationOverride:false, sensorDataPoints:[:], geolocationOverrideDisableTime:null]

Hope that helps. Many thanks & keep up the good work!

Hi, quick update for anyone having trouble using the Hot Water. You need to edit tado-connect.groovy line 1812 from:

if(deviceType == “WATER”)

to be

if(deviceType == “HOT_WATER”)

Hi Stuart, I’m new to SmartThings and Git, I can try to push the change to your GitHub repository if you like, and if you can give me instructions, else perhaps you would be good enough to take a look and if this fix is good add it to your next release when you get a chance please?

Going to see if I can get the rest of my “Cleaner” mode working now…

Many thanks again!

I have just updated the smartapp to v2.5 which includes your fix, thanks for debugging this and picking it up. must have been introduced when i moved everything over to the SmartApp. goes to show no one else uses this for hot water control :wink:

Thanks for that. - Used your Tado device handlers with CoRE and SmartThings presence keyfob for Cleaner so she has hot water and heating when we’re on holiday - Bought you a beer.

1 Like

@Fuzzyligic Thank you again for all of your help and sorry for the delay - Donation sent! Please have a beer on us!

1 Like

@Jnick Many thanks much appreciated, Beer drunk and very much enjoyed indeed… :stuck_out_tongue:


I take it that you have now resolved your issue?

Hi there, yes its resolved therefore I deleted my message. I had to login to the device in the app itself. Not only in the IDE.


Hi @Fuzzyligic
I’ve had a few issues which has meant I had to delete my presence sensors and heating integration.
I also deleted the DH and Smartapp.
I re-installed both.
When I click on the Tado (connect) app, I get presented with a page to put in username and password.
When I put them in and click next, I just get a blank page and nothing happens.
Any ideas?

I have worked out the problem.
I have had to comment some lines as per screenshot below.
This now works OK.


ok that makes no sense to me as that code to get a token needs to occur to get the callback for the auth process. if that was the bit that was failing, you did have oAuth enabled on the smartapp didnt you?

Doh!!! No.
Just did it and, well there’s a surprise. It works. lol.
Sorry about that. I shall disappear from whence I came. :blush:

1 Like

Hi, will the DH work with the Tado Smart Radiator controls?

Yes it does

Great! Do you know if I need the Rado bridge or can they connect directly to the St bridge?

you need the Tado Bridge, as the Radiator Valves communication protocol is propriety to them. once you have them set up in the Tado App via their bridge, you can then use my Smartapp/Device Handlers to control them from smartthings

Hello, first of all, let me thank you for the time you spent to develop such good integration…

I’ve just install the cooling and present handlers and it work great!

I have some issues:

1- when I manually change the temperature from the ST app, the fan gose to high speed automatically… so a have to change it again to low…

2- although i have only install the cooling handler… I still see 4 up and down buttons ( 2 in red and 2 in blue) and i don’t know what is the benefit from having it…

3- in the settings it ask for 3 entries: heating and cooling temperature and the override … which i think i did not get the benefit from setting it…

Thank you agan for your time!