CentraLite Keypads

keypad
dth_security

#980

@zcorneli - So I unplugged my hub and let it sit for a day without power or batteries. I installed the DTH from the link in 752 then reconnected the hub and kept it several feet away from my other devices. I put the keypad in pair mode and after about 2 mins. it recognized it!!! I then installed and setup ULM and SA separately. Now the keypad is cycling the bottom three lights. Im not sure what I did wrong but at least my hub is recognizing it now.


(Zack Cornelius) #981

Use the DTH from post 906 (or thereabouts), it has a few fixes specifically
relating to this issue. You’ll need to re start the whole pairing process
though

When you go to pair it, once smartthings recognizes it the network light
should move to a rapid flash. After it’s in the rapid flash mode, tap the
tamper switch once. After some time (up to about 10 minutes apparently),
it’ll beep, and finish the pairing process, and the network light will go
solid. After that, configure ULM and SA, and everything should work again.

–Zack


(Al Hughes) #982

I tried turning off 2.4GHZ on my router and then paring. Still no joy.


(Zack Cornelius) #983

@agh1701,

It looks like @Neight’s solution was to have the hub off (with no batteries in it) for 24 hours, then attempt to pair (Potentially waiting a bit). Can you try this?

–Zack


(Al Hughes) #984

@zcorneli,

Will have to try this on the weekend. Thanks.


(Zack Cornelius) #985

So, have a few updates:

Some updates to the DTH code (Much of this based on @RudiP’s code improvements):

  • Better tiles! (Much nicer view in the app)
  • Better support for Beep (and the Tone capability)
  • Support for reporting panic as a contact and the button (Some applications only accept contact as a device)
  • Support for reporting motion events when the keypad wakes.

Updates for SmartAlarm:

  • Chime support! (Add your keypads to the “Chime Devices” list in the “Notifications” page to get chimes to work)
  • Support for enabling or disabling chimes for specific zones. Contacts are on by default, others are off by default.

Also, I’ve confirmed that while using User Lock Manager, 2 keypads works flawlessly. This is also true with SmartAlarm (Control, status, and chimes)

Links are same as primary links previously, but provided for convenience now.

DTH (Same link as before):
https://github.com/miriad/SmartThingsPublic/blob/keypad/devicetypes/mitchpond/centralite-keypad.src/centralite-keypad.groovy

ULM (Same link as before):
https://github.com/miriad/SmartThingsPublic/blob/ULM-keypad/smartapps/ethayer/user-lock-manager.src/user-lock-manager.groovy

Smart-Alarm (Same link as before):
https://github.com/miriad/SmartThingsPublic/blob/SmartAlarm-Keypad/smartapps/statusbits/smart-alarm.src/smart-alarm.groovy

–Zack


[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps
Second Version of Smart Alarm Device /Type for a Status Dashboard
(Rudi Prunzel) #986

Nice job Zack. I’m glad you’ve found some use for my updates to the original DH. Thanks to Mitch (@mitchp) for creating this device :wink:
I have 3 Iris Keypads and made the changes to my needs, like most of my devices. I’ve started to publish the code to GitHub but then I got busy and never had the chance to publish the changes here in the forum. I’m also glad that you guys found it.
Cheers :sunglasses:


(Zachary Evans) #987

I can not find chime devices in the notifications page…i do see it under zones


(Zack Cornelius) #988

Sorry about that, I was dumb and didn’t actually push to github. Should be present now.

As a note, You’ll probably want to go into the preferences on the keypad, and change the default beep length to 1 (A single beep), otherwise the “chime” will actually be 3 beeps by default.

–Zack


(Zack Cornelius) #989

@RudiP

If you’ve got other changes pending that you think would be useful, feel free to either submit a pull request to my repo, or just post the code somewhere and point me to it. I’d like to make this DTH as versatile as I can.

–Zack


(Ben Lebson) #990

Thanks for putting in the work Zack. It might be worth creating a new post so that you can have better visibility for your code. I would suggest something like “(RELEASE) Centralite 3400-X Keypad and Lowes Iris Keypad DeviceType”. This would allow users to find all of the most up-to-date code and information easily.


#991

So the DTH in 906 did not work for me, but when I went to post in the forum last night, I noticed some updated DTH and Apps. I installed the newest DTH after letting my hub sit overnight, I was able to get the keypad to pair this morning as I left for work. I added the new smart apps at work and am excited to see if the keypad is working when I get home.


(Zack Cornelius) #992

All:

I’m moving this to a new topic, here:

This should make it easier to keep track of which versions are newest, and move this into a shorter thread for new users to see what’s going on, and easier to announce new features


#994

Hello Guys,

Thanks for this great work! I have one question.
If I only enter the code at keypad it jumped to armed home.
If I press the middle "walking (away) button and enter the code it jumped to armed away after 30sec.

So but HOW I can disarm the keypad and showing them green LEDs
I’m using the stock Centralight 3400 Keypad with the buttons A and B and not off and on.
For setup I used the user lock manager smart app.

It would be great if you can help :slight_smile:


#995

Hi all,

I’m having a problem re: pairing the Iris keypad. I’ve used the advice: here and added the IDE & SmartApp.

Firstly, it says go to IDE - My Devices - Find Thing. Find Thing doesn’t appear, but there is an option to add an item. It asks for a Device Network ID - how do I find this? EDIT: I’ve found it somehow because it’s partially added, so now I have the item half added to the Android app but it won’t configure because I assume there’s no Smartapp installed even though I’ve done exactly that and the Device Handler? The above article says go the Marketplace in the Android app and the smartapp will be there, but they’ve changed the layout of the app recently and I can’t find it? I can see some custom apps people have made but not the one I’ve just added.

It also asked for the item to be added to either a Hub or Location. Both drop down lists are blank. I’ve tried to add a hub but it tells me ‘use your mobile app to add a hub’, which is strange as it’s right here and controls many devices fine. I added ‘Home1’ and I could add the device there, but I think that might confuse things?

Further edit, I have got a bit further. The Smartapp wasn’t saving for some reason and now it appears under a new section called MyApps in the Android app. Now it won’t allow me to add the keypad because I can’t actually select it in the config screen (see the first field ‘You can’t currently add this’ in the screenshot below)

Any advice would be appreciated as I’m really having a hard time getting this stuff to work


#996

Android screenshot of error


(Zack Cornelius) #997

That info is currently out of date. An updated Device handler and Smartapp selection is available in the new thread, here:

The major problem you’re running into there is that you need to pair the device through the mobile app, and not through the IDE. The newer DTH and SmartApps though are a bit more reliable (Especially with respect to the pairing process), and feature filled. There’s a set of instructions in the first post of the new thread.

–Zack


#998

Ahhh thanks so much, installed new code and it instantly started to connect.

Only issue I’m having now is with Smart Alarm, it’s telling me I can’t select a camera to record even thoughI have the Samsung Smart CamPro which is already paired with the hub?


(J Bentz) #999

How are you guys mounting this? Has anyone come up with a creative way of getting it to sit flush with the wall?


(Jordon) #1000

Could you please help me. I am having a lot of trouble setting up my iris keypad. New to smartthings but have basic ida of what I’m supposed to do. I applied the handler and smart app but it keeps coming up as a thing and can’t do anything with it. Could you help me fix this?