[OBSOLETE] OSRAM Lightify Smart Dimming Switch(Ultra-fast Zigbee Handler)

If you buy one and check the logs, I can add rudimentary support. I need logs for pairing. You can dump them at https://pastebin.adamoutler.com

I am not technical at all so my question may be stupid. Is it not possible to issue the on/off commands upon which button pressed regardless of the current status of the bulb?

Any reason why this would have just stopped working? I have the dimmer tied to a single bulb. All of a sudden, it no longer responds to a button press or hold. Looking at the logs of the dimmer, it’s seeing the presses, but the bulb isn’t responding to it. The bulb is working when controlled directly and through other smart apps.

Where should I start troubleshooting?


Well, that was weird. Somehow, either the network ID of the bulb changed or the ID got changed in the setup of the dimmer. Either way, I edited the ID in the dimmer and all is good now.

Anyway to make this work with a group of LIFX bulbs?

You are not the only one to experience this. I’ve seen others report it, as well as I had it happen once. Not sure if anyone ever figured out why. Also, I believe it’s the actual ID of the bulb that changes, not the dimmer settings.

+1 I mistakenly bought this switch and now desperately trying to figure out how to utilise it. i posted my query on another thread.

You’re talking about a different switch?

Don’t know if anyone’s made a device handler for it.


How to I extract the logs? Sorry haven’t done it before, thanks!!

I have 10 lights that I’d like a single dimmer to control, but it only lets me configure 5. I got 4 working, but sorry, I’m a bit new to this… how can I assign 10? Thanks for all your work, this is great!

Adam, are you still willing to try to add support for the 4 button version? I have the logs for you. :grin:

Hi! So I ran through this and I’m to the point where I need to enter the endpoint ID. (I gave it a NEtwork ID name.) however, I can’t seem to find it under the device. I’m trying to control a GE Z-Wave Dimming Switch but can’t seem to get it to work.

I’m not a developer but I’m pretty sure this device handler is meant to handle zigbee bulbs only. Your z-wave switch probably doesn’t have an endpoint ID because it’s z-wave, not zigbee.

1 Like


Thanks so much for building this handler, worked like a charm. I bought this switch as a back-up in case friends / family need to use a certain set of lights and don’t know the google home prompt.

Now I’ve just been tweaking to see if I can get this switch’s on/off status to update when I switch the lights using google assistant (i don’t want this physical switch to be the master).

Do you know if there is a way to get the this switch’s On/Off logic to work with CoRE? I added in the “Switch” capability so it shows up in CoRe as a switch, but any on/off logic always evaluates as “False” regardless of of the switch state.

The best I can tell is that that “OnValue” and “State.On” don’t supply the info CoRe needs to evaluate On/Off logic. I’m totally new to this (about a week in), and while I’ve tried to add in some logic i thought might work from other DH, I’m floundering.

I’m hoping its something simple like if getOnState() returns True, some other variable CoRe recognizes = “On”

Thanks Again

1 Like

I’ve been doing a rewrite, slowly, over the last few months with all of the suggestions I could handle. This code aims to address the following issues:

  1. Improved interoperability with smart apps
  2. Alexa capabilities
  3. Adds proper Switch capabilities
  4. Adds proper LevelSwitch capabilities
  5. Adds numbered Button capabilities
  6. all 5 lights are handled


  • You tell me. My uses are satisfied by the original release.

edit: Note - this is not a direct upgrade. This is a new device type with new features which I am doing in order to keep things stable. The original device type was recently updated with the code I’ve been running for 3 months.

What is the “theswitch” light that is required? I see it in the input, but not seeing where it is called out to do anything with.

Minor bug: Tried to tie two of the switches together using DIM with me. They do not seem to track together.
(Is this because it is actually a button instead of a true dimmer?)

Otherwise, overall action seems better than the original code. Seems to always switch on to 100% now (was not doing that for me with the other code for some reason.

TheSwitch is an experiment I’m running with a smartapp which has not yet been completed. It is unpublished. The basic idea is to use a smartapp to keep the network id up-to-date. Ignore it. It is unused at this time. Eventually a smartapp will subscribe to the events generated by the buttons and ensure the commands will reach the lights.

As for DIM with me, is it possible your bulbs are too far away to get the commands 100% of the time?

All the bulbs are within 10 feet of the hub and switches.

For some reason, DIM with me just does not seem to like the OSRAM bulbs. Whenever I use DIM with me directly to the bulbs, or with a virtual dimmer, I always get weird dimming values (a couple only come on to 50%ish). This also happens occaisionally with this switch/button. Sometimes, 3 of four lights will come on to 100%, but one stops at 10% or some other really low value.

Was hoping the new switch capabilities would let me sync the two switches/buttons but nadda. At least DIM with me sees them now. Will have to try fiddling around.

This handler can only control one bulb then?

It will control up to five zigbee bulbs

1 Like

Can I tie them to zigbee lamp dimmers, or appliance switches or is it specific to bulbs? Is there any technical reason why it can’t handle more than 5 bulbs/devices (aka, can I just update the loop logic for more devices and whatever code there to configure them?)