[OBSOLETE]Intermatic PE653 Pool Control System

Intermatic PE653 Wireless 5-Circuit Pool/Spa Control System

I have created a device type for the Intermatic PE653 the replacement for the discontinued Intermatic CA3750.

This is a cool device it has two temp sensors an antenna extender with cat5 and variable speed pump control.

I still have work to do but it has basic function now.


Very nice. My dad has this intermatic system and I’ve been trying to convince him to get the SmartThing kit…this might just push him over the edge.

I’d love to know what you can control, how it works and any other hands on details you can give once you get to that point.

Looking forward to seeing this progress!

Here is a smart app to protect the pump from freezing.

I need to change a few things like a check to see if pump is already running. Now it will send on or off command every 10 minutes regardless if pump is on or not. It does work though I have been using it for the past month and it has not failed me yet.

I updated the device type form the MultiInstanceV1 Command Class to the MultiChannelV3 Command Class.

Is there any new development in this area? I know the intermatic product well and I would love to have full control over it. Especially temp control.

I am also considering using this pool timer so long as I can use valve control (so I could automate changing from standard pool mode to switching the pump/heater/valves to the correct settings for my hot tub). Thanks for any help with this!

I really want to use this device? Can you walk me through it? I done all that’s in your readme but the part where I past your code, I got lost. Where do I paste it? Do I delete all the things that it automatically create and put your code in?

Okay, I found out how to add the device-type. Now how do I get the device ID of my PE653?

You can simply assign a device ID - like 12345 - should work. Please let me know if you’ve had success using this device with smartthings. It will appear in your dashboard as a device with 5 switches. I don’t actually have a PE653, but am considering purchasing one so I loaded up the device. Do you have any valve actuators or just a pool pump? Please see the screen shot:

Hey there, @mbial Matthew, I have a PE653 sitting in front of me and I followed your installation instructions as best as I could. When I got to the part where you say, “Copy and paste the code into the IDE”, could you provide more detailed instructions as to exactly where we paste what? I copied and pasted and clicked “Save”, but received error messages similar to:

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script141452217615711895585.groovy: 51: Repetitive method name/signature for method ‘java.lang.Object parse(java.lang.String)’ in class ‘script141452217615711895585’.
@ line 51, column 1.
def parse(String description) {

It seems like there is some auto-generated code (from the device-type creation process) that conflicts with some of the def statements in the pasted code.
I did not add the freeze protection code yet. Does that code just get appended at the bottom of the IDE window?
FYI, I am a novice programmer, so please be kind. :blush:

@PatA To get things working, you need to first create a device type with all the correct capabilities, attributes, and commands (see the attached screen capture). Once you’ve done that, completely delete the code ST automatically creates for you and replace it with the GitHub code. Let me know if you have any better luck - I just created this DeviceType again without issue or errors.

@mbial - I figured that was the case, so I commented out the auto-generated code, saved, and published. I got the same dashboard as you, showing the 5 switches, but tapping any of the switches does not control the PE653. Note that before I changed the device type to the newly create PE653 device type, it used to be defined as a “Switch”. As a switch device type, the app would only control the first switch. I had tested that already and demonstrated that it worked. Now after changing the device type to the new PE653 device type, nothing is controlled.
The icons in the app don’t even toggle between highlighted green and not green.
In the preferences, I set the Booster pump (Booster is misspelled) to “Uses Circuit-1” and the Pump Type to “2 Speed Pump”.

@PatA Please try the code here - I made a small change so it includes the metadata for capabilities, attributes, and commands. Hopefully this resolves things! Be sure to let us know how it goes.


Have you had any success? I’m trying to decide whether to purchase one of these and want to ensure all 5 channels are accessible from SmartThings. @bigpunk6 can you confirm that it was working for all channels for you? Thanks!

First, thank you for getting us this far!

You are getting somewhere for sure. I just tried it today. It does respond to the individual switches. However, when you press a switch, there is a delay, and all of the switches icons appear in the same mode regardless of what they are really doing. If you press refresh, it does nothing. But if you flip to Activity, you will see everything is responding properly. If you switch screens and return to the multi-switch screen, you will see the icons are all responding correctly. So it seems these changes are still required: 1) Faster response to pressing a switch. 2) Make refresh function and display proper activity of each switch.

@matt_coulter That’s great news - about how long does it take before it actually responds to your button push? To clarify, the switch status information does display properly, but you have to leave the device page and then return to it? Do you use any valve actuators with your PE653? Sounds like @bigpunk6 had it just about working - my guess is that there were some changes to the ST API that impacted his original code.

Sorry for the log hiatus

I posted the updated code to gethub.

Thanks, @bigpunk6

What devices are you using with your PE653? I’m really curious about trying out some automatic valve actuators so i can press one button and have the pool go into “hot tub” mode. Do you have any suggestions for refreshing status more quickly? Perhaps Pollster? Thanks for your contributions!

Hey @mbial and @bigpunk6,
Trying the new code now. Happy to have temp readings. The results with the switches are the same. Yes, the switch information does display properly, but you have to leave the page and return to see a true refreshed view, otherwise the screen reports that all switches are either on or off depending on what you did to the last switch you pressed. This pool does not have actuators but others I have installed do (my dad has a pool company and I have helped him install a lot of these units). Switch 4 is reserved for Actuator control if you have the unit setup for Pool/Spa mode. So yes, it will work fine when you just press Switch 4. And likewise, Switch 5 is reserved for Heat Pump on/off if you are using one, so it will automatically kick on if there is a demand. Lastly, while the temp reading is good, it does not do anything when you press the temp icon. But I wasn’t sure if it is supposed to yet. Hope this information is helpful. Like what you all are doing. Thanks!

@mbial and @matt_coulter

I have a thermometer, pump and lights connected now. I also have the problem with the refreshing status. I did have poll configured after a switch command but ST has disabled that. The temp icon has no function associated with it now since poll is disabled.

I know this device is capable of more I just never configured it since I don’t need it.