[OBSOLETE] IKEA Tradfri Button -- help needed (DTH in post 36)


IKEA Trådfri Dimmer
Copyright 2017 Jonas Laursen
Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except
in compliance with the License. You may obtain a copy of the License at:
Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
for the specific language governing permissions and limitations under the License.
metadata {
definition (name: "IKEA Trådfri Dimmer", namespace: "dk.decko", author: "Jonas Laursen") {
capability "Configuration"
capability "Switch"
fingerprint profileId: "0104", inClusters: "0000,0001,0003,0009,0B05,1000", outClusters: "0003,0004,0006,0008,0019,1000", manufacturer: "IKEA of Sweden", model: "TRADFRI wireless dimmer"

simulator {
	// TODO: define status and reply messages here

tiles {
	standardTile("switch", "device.switch") {
    	state "off", label: "Off", icon: "st.switches.switch.off"
        state "on", label: "On", icon: "st.switches.switch.on"


// parse events into attributes
def parse(String description) {
//log.debug "Parsing ‘${description}’"
def map = zigbee.parseDescriptionAsMap(description)
if (map.command == "04") {
if (map.data[0] == "00") {
sendEvent(name: "switch", value: "off")
} else if (map.data[0] == "FF") {
sendEvent(name: "switch", value: "on")

def configure() {
//log.debug "Configure called"
["zdo bind 0x${device.deviceNetworkId} 0x01 0x01 8 {${device.zigbeeId}} {}"]

Thabks, that sorted it

Hi there,

I’ve added the DTH and it recognised the puck, and once or twice the devices status has changed from on to off, but I can’t seem to set up the Tradfri dimmer, it doesn’t appear to be available to webCore at all.

Have I missed something basic? This is a DTH to enable the Tradfri dimmer to control smart stuff via smartthings?

Many thanks.

Just picked up 2 of these. Any tips on getting them to pair to my ST hub? It doesn’t seem to see either when I reset the remote and tap or hold the config button.

I think you hold the button until it lights then press frantically for 6 seconds, however, it’s a bit pointless as I haven’t been able to do anything but turn on at 100% and turn off at 0%…anyone else get this to actually dim a light via smartthings?

Try removing the battery for 10-15 sec. That worked for me… :slight_smile:

This post has a great guide…:


I may be mistaken, but it looks to me like this device type handler will allow the puck to be added to the SmartThings network so it can then independently control Tradfri bulbs that are connected to the same network by talking to those bulbs directly. But it doesn’t look like the puck is sending its button presses to the hub, so you would not be able to use it to control any other SmartThings control devices or to change modes or anything like that. That is, it’s not acting as a button controller like a minimote. It’s just able to control some of the same bulbs that smartthings can control.

So the puck becomes a parallel means of control, but it wouldn’t do you any good with webcore or SmartLighting.

If I’m wrong on this, hopefully someone will let us know.

That is exactly what it does.
And it works very reliable - only downside is, that it can not be used to change color temperature.
Dim up/down, and on/off works like it should, but there are no status sent back to the ST. :slight_smile:

1 Like

I was never able to get them to pair to my ST hub. :disappointed_relieved:

So if the remotes are not reporting anything to SmartThings, and they cannot be used for anything connected to SmartThings (except for the IKEA bulbs), why do we need a device handler for them? Or why do we even add the remotes to SmartThings in the first place?

On the contrary, my SmartThings can no longer control the bulb after I paired it according to the instructions here. Anyone else having the same problem?

You need both the remote and the bulb paired to smartthings before you pair the remote to the bulb, otherwise the bulb will lose its connection to the hub in my experience.

Also do not reset the remote before pairing with the bulb as this causes problems too. simply do the long press pair procedure with the bulb, after pairing both with smartthings.


Thanks! That did it. Removed everything and started from scratch. I think I reset the remote by mistake while pairing it with the bulb.

1 Like

Is there perhaps an older version of this remote (or older firmware) that simply won’t pair to SmartThings? I’ve tried and tried and tried again to get the 2 remotes I have to pair with no luck.

I’ve found some of them pair really easily and others are really awkward and take several attempts. same with the bulbs actually. Can you describe the process you’re using to try to pair them?

that said, i don’t know for certain that there isn’t an incompatible version.

Yes. The firmware was updated around October 2017 and they converted it over from a proprietary protocol that didn’t work with much else to something that was much closer to the standard so that they could add HomeKit and Alexa compatibility to the bulbs.

I believe the only way to update the firmware is with the IKEA Gateway.

Thought that might be the case. I’ll try to trackside a gateway.

Got an Ikea gateway. Paired the remotes to it without issue. Fairly quick. Left it alone for a while and 1 or the 2 remotes received an update (1.2.214). Took the updated remote and again tried to pair to ST.

  1. Quick tap pairing button 4 times to reset. Remote flashed red.
  2. Waited at least 10 seconds.
  3. Started searching for a Thing.
  4. Placed remote directly on the ST hub (I’ve tried every side) while holding in the pairing button.

No matter how long I wait or how many times I try, the remotes still won’t pair. I even tried a brand new remote that came with the gateway.

Am I missing something?

1 Like

I’ve had success with different remotes using diffferent techniques. Try putting the hub in pairing mode after number 4, instead of at 3…

The remote, when it does pair, will simply show up as “thing” ifi remember correctly,…

If it is the 5 button puck remote, remove the battery for 30 sec after you reset it.
That works every time for me… :slight_smile:

Don’t know about the little twist remote - but maybe the same?

Yes, 5 button remotes.

Still no luck. Any chance someone could post a quick video? Just don’t understand why 0/3 won’t pair.