[OBSOLETE] Honeywell Lyric Water Leak Sensor Connect

Ok… so I think I have found and fixed the setup bug… I aded a display in F setting also during setup. If you already installed, hopefully you don’t have to reinstall. To enable display in F go to the lyric (connect) smart app and click next at the top right until you see the setting. It’s set to on by default.

All, I think all of the errors on install were caused by Honeywell Rate Limiting my API key. I have created updated instructions and adjusted the code to not include my API key and secret. You will need to follow the instructions to obtain your own API Keys and enter them into the settings of the app. Sorry… I tried to make it easy for you all :frowning:

Also, It may be a good idea to remove the current app from smart things and just reinstall it completely.

1 Like

Hi guys! I bought this lyric as a result of a major flood in my basement last week. I’m having a problem though, I followed the instructions posted to a T, but when I go to add smart app-> my apps -> lyric connect it shows “click to enter Honeywell credentials”. When I click that, it says “code 401 invalid client”.

I have been at this all day and can not figure it out for the life of me, very frustrated. I am new to this platform but am not a complete tech idiot. What am I missing?!?!?!

Please help!! Thanks in advance :heart_eyes:Screenshot_20180309-181110

Try it again after clicking on live logging and PM me the logs produced from the app.

System will not let me send you a PM.

That’s odd. Maybe because you’re a new user. Did you follow the updated instructions on the Git page? enabling oAuth and all?

When I enter the URL Callback on the Honeywell Developer Site I get an error. Is anyone else having this issue?

I am also having code 401 error , any way to resolve this

I set this up and connected 2 Lyric leak sensors last fall and they’ve been working great. However, I just added 2 more to my setup and they aren’t seen by the Lyric app in Smartthings. It has been several weeks so it clearly isn’t going to show up by itself at this point. Any ideas on what I should be looking at to get Smartthings to see the new sensors?

To get them to show up, you have to uninstall the app and re add everything. I’ll see what I can do about making some changes to allow you to select new devices without having to reinstall.

Thanks, that did it! That would have been my next step but I was trying to avoid it if I didn’t have to. It was easy though other than having to remember my Honeywell password lol.

Hello, I already installed everything but when I setting up the sensor in the mobile app, its see all my sensors and when I continue getting error connecting to my Honeywell account with smartthings.

here’s the logs

help is very much appreciated. Thanks

It looks like token refresh failed. Try deleting the app and re adding. If it still happens, I’ll have to add some extra code to allow for re auth.

Hello Josh,
I already delete and reinstalling the app but still getting same issue. Thanks for the help.

Here’s the error I"m getting when trying to add the apps from my mobile smartthings apps.

Seems to be a problem with Honeywell rejecting your token refresh then. Try deleting the app in Honeywell and creating a new app and api token. I’ll take a deeper look and make sure they didn’t change something when I have some time.

Can you confirm you completed the part of the instructions at the bottom enabling OAuth and entering the API key and secret from Honeywell developer account? If you haven’t already, I would delete the Honeywell app In your dev account and re create it. Updating your app settings with the new api key and secret, then delete the app from smart things and try again. I think Honeywell has one region that the api is configured differently in as someone else had a similar issue you did and I was not able to reproduce. I don’t know if she ever got it working.


Yes, I completed and set the APi Key and secret key and enabling the OAuth and actually I tried to delete and create new key in honeywell dev site 3 times but still same issue. Is that possible that Honeywell didnt give authorization because I located in Canada?