[ABANDONED] Fibaro Wall Plug ZW5

Shouldn’t be a specific sequence. But if the plug is off, and no load is connected I suspect it doesn’t receive any commands at all. Try changing it when the plug is on and a load is connected…

No problem, thanks for the code and advice, am prototyping some smartThings integration!

The plug is at my house and like I said there isn’t any errors after you’ve done the setup, so I’ll have to go home and re-connect the plug, will post the stacktrace later.

1 Like

I’ll test without load today!

1 Like

Thx! Thats great.

Jon

Hi Jon

Can confirm, the switch is unreliable without any load connected to it :slight_smile:

Regards
Simon

Thx! I have returned the switches today.

Has anyone good experience with Aeon Smart Switch 6?

Regards Jon

Hey @ulfthomas74 did you ever hear back from Fibaro regarding these plugs?

Anders,

There might be some progress on this actually. Some of the guys on http://hjemmeautomautomasjon.no has found that the behaviour might stem from the fact that group 3 on this switch is set up to turn off other devices when the load is low.

So I’ve removed the group associations for 2+3 in the device handler, now only associating group 1. Published a new version to Github, would be great if anyone has time to test the low load scenarios with the new handler. :slight_smile: Maybe @Simon_Moller is able to test?

Anders,

Interesting! Good work:)

That link didn’t work for me (about the group 3 associations), but to me, the behavior being described sounds a lot more like the overload parameters. Because of the fact that people have to push the B button to bring the switch back online. So it sounds like the device is shutting itself off, not that it’s the issue with it trying to control other devices when its own load drops ( which would be the group 3 issue).

The address wasn’t meant as a link, it just got parsed by the forum I think. :slight_smile: But the discussion is below, Norwegian forum though. :slight_smile: They are reporting that stuff works when removing group 3. But I havn’t gotten round to testing it yet. :slight_smile:

1 Like

Tested a little bit now and can’t really see any difference. Tested with only associating group 1, and changing parameter 21-22. :frowning: Sorry for getting your (and mine) hopes up. :slight_smile:

If anyone feels inspired take a look at parameter 21-23 and/or the association groups. I’m just going to leave mine be and avoid buying any more of these for now. :slight_smile:

Just a comment - I have 2 of these wall plugs and now experience the same issues - will only work correctly with a load. I also had a hell of a job getting them to pair with ST - the normal 3 x presses on the button didn’t do it - I found I had to keep clicking the button until eventually ST got it. That was yesterday - prior to that I had them on a Z-WAVE.ME system where they worked and paired faultlessly - with and without a load.

Another thought - turning the switch off doesn’t appear to be the problem, its turning it on with no load that kills it - and it stays dead for a long time (1 hour?). Can there be some kind of spike that is seen as a panic situation and subsequently disables it for this long period. Something that needs masking / ignoring?

I really don’t know. I’ve factory reset mine so everything should be default. Do you know if the zwave.me is modifying any parameters?

It sounds weird that it should work on that system as the behaviour seems to be consistent when you use the physical button too. Anyone tried how it behaves before it’s paired with ST?

I have both with loads but its not really reliable. I can switch on/off with the app and they follow but if I do it too fast (or something) they get stuck and again I have to wait a long time to clear the condition. I also notice on the app that when I re-enter the ‘My Home’ screen, from anywhere, both appear ON - but they are not! Then I touch the screen buttons both clear to OFF and the switches are still OFF. The I can touch again an the buttons and switches are back in sync. I am still suspicious over the pairing difficulties I had with these wall plugs - all very flakey. I have just excluded a Fibaro window/door sensor - ST got it on the first attempt. Then paired again - also first shot. I will put one switch back on the z-wave.me system and note all the settings - will let you know.

I confirmed that the Fibaro Wall Plug works correctly on the Z-Wave.me system. I am no expert but I think the Command Class definitions describe the device set-up. I have included some of the screens but only the first (Basic) Command Class printed text definition - I have the others and can attach if you think useful.


Hi @anderssv,

No, not one word.

A different implementation has been posted that is not affected by these problems. Let me know if any of you check it out: [RELEASE] Fibaro Wall Plug ZW5 (Z-Wave+) DTH

Tried the new DH and it works for me, tried with low-load led lights and also nothing plugged in - no issues so far.

1 Like