NST Manager Real-Time Events

Donated, where do we get the server.js files?

@tonesto7 Does this help with getting around the rate limits? It seems like Nest has recently gotten more strict about how many you can send in a period of time.


I doesn’t really change that but our queuing mechanism in the smartapp is pretty advanced to where you will never hit the rate limit. The real-time events are about subscribing to the nest events and sending them to ST within 2-3 seconds of them happening.

@tonesto7 thanks for all your work on this. Im trying to trigger a porch light on a nest cam motion event. Will this work for that or will the delay be to long?

This is exactly what i use it for in my setup. There is about a ~4-5 second delay

HI every one. I had a hell of a time trying to get just the app to work. I am at another predicament. When I try to sign into my nest account to configure the app, it responds with something went wrong. I am using the most recent version and the nest prmary account. Any suggestions?

I assume you are trying to get NST manager working?

There is another thread on that.

Please ensure you follow the instructions carefully

Still need help with Documentation for Real Time NodeJS streaming service?

@tonesto7 How can I get a hold of the install instructions and source for this? I have a raspi ready to go! Thanks :slight_smile:

@tonesto7 also interested in this if you are still looking.

I have a Mac that is always running. Can I use this?

I have a Nest Hello on the way…so want to use this for it.

@tonesto7 is this still available? Thanks!

It is… I’m just on vacation. I will be back tomorrow and can send you instructions

1 Like

Would also love to have the instructions

Is there anynchamce I can get the code for this and setup instructions?

@tonesto7 got the fix installed for the state manager and it rocks! Thanks. Now that I can get in my SmartApp again, I’ve moved on to the REST service. Been looking forward to this feature. My journalctl log is saying that a token is missing on the SmartThings side of things.

Can’t send Status back to SmartThings because the enpoint url or access token are missing…

I’m guessing this is where the donation only part comes in. (Gladly sent one your way). Take your time and thanks again for the great work.

Update: following the GitHub instructions for the token. Can’t seem to figure out what redirect URI I should be using. I’m trying https://graph.api.smartthings.com/oauth/authorize or ./oauth/callback … Is either right? It takes me to login and I select my location but then I get:


You will need to go into the NST Manager > Preferences > Polling Settings> There is a section there about discovering the streaming service

yes, I’ve got the Rest Streaming turned on and the IP address entered and port 3000 unblocked on the appropriate IP (where my RPi is running your rest server) but the Auto-Discover never finds the NST service. This is because the systemd service just continually restarts the server almost immediately with a message saying that I don’t have authentication token or something along those lines.

For anyone else that might have this issue, my Roomba980 Rest server had port 3000 taken already. Run

sudo lsof -n -i :3000 | grep LISTEN

To make sure this isn’t the case.

@tonesto7 I hate to come at you with another issue but I can’t seem to figure this one out on my own. The Rest service is running great and the NST Manager app says its Active and the logs on my RPi are logging and my IDE is logging. I created a couple of simple Webcore pistons to trigger a hue bulb to flash when motion is detected on a Nest camera just to test it out but I’m seeing no difference in response time. The average response to me walking in front of the camera to the bulb flashing is about 90 seconds. I’ve tried with 4 different cameras and I tried the smart lighting app to eliminate webcore. I updated the nst streaming node and changed/unblocked port to 3003 as we discussed last week. Any ideas?