NST Manager - No Devices were found

nest

(Daniel T Drake) #1

I removed and installed all parts of the NST Manager this morning because both of my Nest devices (Thermostat & Nest Protect) stopped working in the Smartthings App some time ago. After the reinstall, I created a Nest Developer account in order to obtain the needed Client ID and Client Secret fields for the Nest Manager SmartApp in the Smartthings IDE.

After entering my Nest login credentials in the NST smartapp on my phone, I note that the Thermostat and Nest Protect devices don’t show up. They are not shown in the Device List of the IDE, either.

I rebooted my hub - no change.

Help!


(jkp) #2

You set up all your permissions correctly in your nest developer account? Also, did you copy your client ID and secret into the right column and not into the left column where the field names are?


(Daniel T Drake) #3

Yes to both questions. 9 permissions in the developer account. Right out of the instructions. Client ID and secret into the right hand Fields.


(Eric) #4

It is acting like this is not the primary account for nest. Please check that you are using the primary account, and that the instructions for creating and entering the token are all correct.

After that a private message with logs would help. I expect this is a setup problem in smartapp / IDE / nest token.


(Daniel T Drake) #5

Thanks, Eric. Yes, I am using my primary Nest account for the credentials in the Android SmartApp,. I have gone back through the developer account setup a couple of times. I initially found a mistake in the Away settings (I had set “Read” instead of “Read Write” and I had not dealt with the Camera settings because I wasn’t using a camera - just a thermostat and a Nest Protect). I fixed both those settings, recopied the Client ID and Secret values into the NST Manager SmartApp object in the IDE, then in the Android SmartApp reset the Nest Token and reentered my Nest Account credentials. No change…

I’m not sure what logs you want, but I captured the Live Log for the NST Manager while I reset the credentials in the Android SmartApp,.

You said I should send the log to you in a private message. Not sure how to do that…


(Chris Coffey) #6

UPDATE: I did a complete delete of the app from SmartThings App and IDE and then did a reinstall (took 5 min once i figured out how to uninstall NST-Automations). Everything seems to be working.
Old: I’m having a similar issue. I just updated the NST Manager app and deleted both my camera and thermostat because they weren’t working (it looks like they stopped working a while ago, before I updated the app). I then followed the instructions for the creating the NEST Developer account and copying in the OAuth Client ID and Secret.
I did previously have OAuth enabled, i’m not sure if that would cause an issue, it looks like it may have 2 sets tokens.
When I now go into the NST Manager through the Smartthings app it does not give me any devices to add.


(Daniel T Drake) #7

Chris,
I’m still stuck in the same spot. I’m thinking that the Smartthings/Nest integration has just gotten too complex. I’m thinking Ecobee…


(Chris Coffey) #8

Dan,
I was thinking the same thing but i must say i like some of the Smart Features in NST-Manager like the eco setting if sensors are left open (back door is left open for 2 min or more and the AC switches to ECO mode). Maybe if I keep having issues I’ll do the same.
Have you tried a complete re-install? Do you want me to send you a write up on the steps I followed?
-Chris


(Daniel T Drake) #9

Yes. I did a full reinstall after removing all of the related objects in the IDE - devices, smartapps, device handlers. Pretty frustrating.

The Android Smartapp never worked entirely right. The history displays would work once, then would require force-closing the app before it would display a second time. I first thought this was a phone problem, but it was the same across several Android phones and tablets.