NST Manager Manual Mode

Below is a copy of the bug a issued today. Bug I was hoping someone else ran into this issue too.

I love the feature that allows myself to make schedules based on remote sensors temperature. That feature is solid and works very well. But there are times when my SO wants to raise or lower the heat. So I created a button that activates a ‘Manual Temp’ mode that isn’t part of the schedules. I even went one step further and added button must be OFF to enter schedule mode. I thought I had it working, but Watchdog feature of NST allows cancels out the temperature command with a "whomadechanges ".

Verify the following before opening an issue:

  • You followed the Nest Developer documentation here? Nest Developer Account Creation
  • That OAuth is Enabled for the SmartApp under the IDE.
  • The SmartApps and ALL (5) Devices Handlers are using the latest code available.
  • You have reviewed the NST Manager Wiki for potential fixes.
  • That ALL SmartApps and Device Handlers have been Published for You in the IDE.

About Your Setup:

  • How many Thermostats?: 1
  • Using the Nest Presence Device? No
  • Using the Nest Weather Device? No
  • iOS or Android?: iOS
  • Mobile App Version: original

Expected Behavior

Be able to adjust the temperature to what I want when in manual temp’ mode

Current Behavior

NST Automation cancels out temperature and resets it.

Steps to Reproduce (for bugs)

  1. Turn on Button to enter ‘Manual Temp’ mode
  2. Change the temperature
  3. NST Automation cancels out temperature

Context

I want to be able to manual adjust temperatures in my house without having to edit the current automation schedules for nst to allow the adjustment.

Please include a copy of your log under the IDE if possible
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:52 AM: info ||| NST Automation - Remote Sensor | setTstatAutoTemps() | Setting tstat [Nest Thermostat - Downstairs | mode: (heat) | heatSetpoint: (65.0°F)]
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:52 AM: info ||| NST Automation - Remote Sensor | setTstatAutoTemps: [tstat: Nest Thermostat - Downstairs | Mode: heat | coolSetpoint: null°F | heatSetpoint: 65.0°F]
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:52 AM: info ||| NST Automation - Remote Sensor | Remote Sensor: HEAT - Adjusting HeatSetpoint to maintain state
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:52 AM: trace | NST Automation - Remote Sensor | setTstatTempCheck: Schedule 5 (5) use Motion settings: false | isBtwn: false | previousBtwn: false | motionOn null
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:52 AM: debug NST Automation - Remote Sensor | scheduleAutomationEval: Eval Schedule Changed from (70sec) to (60sec)
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:52 AM: trace | NST Automation - Remote Sensor | HEATINGSETPOINT Event | Device: Nest Thermostat - Downstairs | Value: (65) with a delay of 54ms
74fc382c-0d35-4b01-94b9-5b6041e7f430 6:06:52 AM: debug Nest Thermostat - Downstairs (v5.4.6) | UPDATED | Device Changes Made by (remSen: Set Nest Thermostat - Downstairs Heat Setpoint 65.0°F) at (Dec 13, 2019 - 6:06:52 AM)
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:52 AM: debug sending data to AT
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:52 AM: debug A sensor event occurred: [name:heatingSetpoint, deviceId:74fc382c-0d35-4b01-94b9-5b6041e7f430, isoDate:2019-12-13T14:06:52.621Z, unit:F, value:65]
74fc382c-0d35-4b01-94b9-5b6041e7f430 6:06:52 AM: debug Nest Thermostat - Downstairs (v5.4.6) | UPDATED | Heat Setpoint is (65°F) | Original Temp: (72°F)
74fc382c-0d35-4b01-94b9-5b6041e7f430 6:06:52 AM: debug Nest Thermostat - Downstairs (v5.4.6) | UPDATED | thermostatSetPoint Temperature is (65°F) | Original Temp: (72°F)
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:52 AM: info ||| NST Manager (v5.6.4) | schedNextWorkQ ALREADY PENDING │ RATE LIMITING ON queue: 0 │ schedTime: 64 │ recentSendCmd: 0 │ last seconds: 145 │ cmdDelay: 4 | runInActive: true | command proc: false | Api Limited: false
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:52 AM: info ||| NST Manager (v5.6.4) | Replacing Cmd to Queue 0 (qsize: 1): 3bDm2k8l7eaSLJdd8KzYXAmjIICHQ_Qb, devices/thermostats, target_temperature_f, 65, 3bDm2k8l7eaSLJdd8KzYXAmjIICHQ_Qb
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:52 AM: warn || NST Manager (v5.6.4) | Command Matches last in queue 0 - Replacing
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:52 AM: debug NST Manager (v5.6.4) | setTargetTemp | Setting Thermostat (Nest Thermostat - Downstairs - 3bDm2k8l7eaSLJdd8KzYXAmjIICHQ_Qb) Target Temp to (65°F)
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:45 AM: debug NST Automation - Remote Sensor | scheduleAutomationEval: Skipping Schedule Change: (22sec) because (7sec) Left
bb4b9765-f1fb-4505-bdad-a96b8b061a26 6:06:45 AM: trace | NST Automation - Remote Sensor | HEATINGSETPOINT Event | Device: Nest Thermostat - Downstairs | Value: (72) with a delay of 45ms
74fc382c-0d35-4b01-94b9-5b6041e7f430 6:06:45 AM: debug Nest Thermostat - Downstairs (v5.4.6) | UPDATED | Heat Setpoint is (72°F) | Original Temp: (66°F)
74fc382c-0d35-4b01-94b9-5b6041e7f430 6:06:45 AM: debug Nest Thermostat - Downstairs (v5.4.6) | UPDATED | thermostatSetPoint Temperature is (72°F) | Original Temp: (66°F)
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:45 AM: info ||| NST Manager (v5.6.4) | schedNextWorkQ RUNIN │ RATE LIMITING ON queue: 0 │ schedTime: 64 │ recentSendCmd: 0 │ last seconds: 138 │ cmdDelay: 4 | runInActive: true | command proc: false | Api Limited: false
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:45 AM: info ||| NST Manager (v5.6.4) | Adding Cmd to Queue 0 (qsize: 1): 3bDm2k8l7eaSLJdd8KzYXAmjIICHQ_Qb, devices/thermostats, target_temperature_f, 72, 3bDm2k8l7eaSLJdd8KzYXAmjIICHQ_Qb
72805b41-b4c5-450e-a6fc-59fdf9081c0a 6:06:45 AM: debug NST Manager (v5.6.4) | setTargetTemp | Setting Thermostat (Nest Thermostat - Downstairs - 3bDm2k8l7eaSLJdd8KzYXAmjIICHQ_Qb) Target Temp to (72°F)
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:45 AM: debug command setHeatingSetpoint(72.0) executed successfully
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:45 AM: info executing ‘/device/74fc382c-0d35-4b01-94b9-5b6041e7f430/setHeatingSetpoint/72?argType=float’ endpoint
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:45 AM: debug sending data to AT
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:45 AM: debug A sensor event occurred: [name:heatingSetpoint, deviceId:74fc382c-0d35-4b01-94b9-5b6041e7f430, isoDate:2019-12-13T14:06:45.616Z, unit:F, value:72]
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:45 AM: debug sending data to AT
6502a7e9-f727-4adf-b6f3-7a7acd9968e5 6:06:45 AM: debug A sensor event occurred: [name:thermostatSetpoint, deviceId:74fc382c-0d35-4b01-94b9-5b6041e7f430, isoDate:2019-12-13T14:06:45.571Z, unit:F, value:72]
6:06:33 AM: info Waiting on events…
6:06:33 AM: info For past logs for individual things go to the My Devices section

You probably won’t see any fix coming. Anthony is no longer maintaining the code due to Google breaking the Works WITH Nest API.

Until they know the replacement API it’s not worth doing any changes.

@tonesto7?

Are you using the virtual thermostat to change the temperature? (you can create a virtual thermostat when you enable remote sensor. It should allow overrides for 4 hours or until next scheduled change.

I suggest you try this.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.