NST Manager Assistance

Hello All
I really need help with NST manager.

So I have added NST manager to my smartapps.
I have created a ID and Secret in nest developer
Default OAuth Redirect URI https://api.smartthings.com/oauth/callback
Copied ID and Secret from nest to smartapps settings
I go to myapps on mobile device, select Nest manager
Click on login to Nest, enter user and password to get a ‘oops! Encountered an error’

What is causing this? Please help.
Thanks

The url above is incorrect. It should be SmartThings. Add a little smartness to your things.

If you have additional issues, please post in the official NST Manager thread.

~```correction~~~ I meant Oauth…not publish…not that this is the issue anyway apparently~~~

I am very new to this app so please take my post with several grains of salt. I had the exact same problem a few days ago last Sunday when I installed the app. In my case I had “published” 2 things instead of just the one outlined in the instructions. I don’t remember the names of the items but when reading the install doc, it’s pretty clear. I just screwed up. I didn’t bother to look for a correction method, I just started over and it only took a few minutes. One thing I did check is that I could log into the Nest Developer site on a browser to verify my username/password/account existence. It’s working very well now.

I tried https://graph.api.smartthings.com/oauth/callback but same error message.

Tried from fresh and still same error.

Make sure there is no space in the clientID or clientSecret at the very end where you pasted it in Settings.

And make sure there is no space at the very end of the callback url in Nest Developer. It happens all the time with copying / pasting.

Did you get the issue resolved?