Missing notifications with latest iOS and SmartThings app

I am running version 1.6.78-591 of the SmartThings app on iOS 15.3.1 on an iPhone 8 and notifications and automations are pretty non existent. Within the SmartThings app I have notifications enabled for all my devices and within the iOS setup Push notifications and GPS are configured, however my door sensors are no longer notifying me and when I leave the house the app is not detecting I have left therefore does not run the routines. If I open the front door and then open the app it sees the front door as being open so communication is working from the sensor to the hub and into the app but it just isn’t triggering the push notification.

I have tried the usual things, re-install app, recreating routines etc. but nothing has fixed it.

Anyone else having these issues? Has anyone integrated with Google Home app and switched over to that, is that any more reliable?

I am experiencing the exact same issue. It seems like it is only Smartthings notifications for me. Other IOS apps are pushing. I’m running IOS 15.4.1 on iPhone 12.

Had the same issue and I gave up and went back to webCoRE until it’s all sorted out. The ST Rule Engine is so dang inconsistent. Notifications work sometimes then out of the blue just stop for no sensible reason. I really wish we could go back to the old days where even though things were flakey then, it was snappy for the most part and 3rd party Apps like CoRE and then webCoRE just worked.

Me too, started three days ago after the iOS update.

I am still on iOS 15.3.1 and notifications are still working so I think I’ll hold off on the update for as long as I can. Surely the SmartThings team get access to beta releases of iOS and can test this before GA?

I’m on 15.4.1 and my notifications keep disappearing. I delete the app, reinstall, and it works for a few days, then just stops. Super frustrating, since I can’t find a better way to re-enable.

Same issue with the Android ST app, v. 1.7.84.21. I receive notifications when I turn on or off the devices from the app, but not when I turn on or off the devices directly (sound notification for lights on or off, works when i control the lights from the app, but no notifications received when I use the light switch itself. This used to work.