Notice: iHome Control Cloud Service Termination (April 2, 2022)

Thanks for posting. This sucks…

  1. I’ve not received any notification from them… I only know because of this post.
  2. Less than 1 month lead time to replace a bunch of my plugs.
    Not nice
1 Like

Sad, but this has been coming for a while. The new products they introduced last year were not compatible with their own app.

The GEENI app is now used to install and operate the new iHome smart home products.
This product is not compatible with the iHome Control App.

One of the nice things about the Apple HomeKit requirement that all devices be able to run locally except for voice control means that even when a device manufacturer does drop support their devices do continue to operate through HomeKit, although potentially with a more limited feature set. But that doesn’t give you smartthings integration. :disappointed_relieved:

Well that very unfortunate that iHome will no longer support their older products. I use it to monitor Temp / movements at a remote house.
I will definitely stay away from any iHome new products !!
Probably will just buy a smart thermostat instead…
Bye bye iHome products.

1 Like

My plugs are still working at this time. Is that the same for everybody?

Mine all stopped working with Alexa ~ Apr-28-22, and now I can’t even press the button on the isp5 to turn a device on at all. UGH

Mine stopped working. The FAQ is wrong. What a bunch of crooks. My home kit doesn’t connect with them any more.

Mine stopped working and will not reconnect even with Home kit.

I have been playing around with my iSP5 outlets every now and then for the last couple of months and I was finally able to add it back to HomeKit this morning. The instructions provided by iHome to reset are not correct, or at least they left out some details.

My trouble was getting the outlet properly reset. To do this unplug the outlet and then plug it back in. Right away the iHome H symbol in the bottom left corner of the outlet will light up white. At almost that same instant press and hold the button on the top right corner for a few seconds until the LED starts flashing green and release the button. Wait a few seconds and then press and hold the button for a while… maybe 10-20 seconds. During that time the LED will flash green, then red and green, then the whole outlet seems to switch off and come back on. From there the LED should be flashing green.

At this point I tried paring to HomeKit using the Home App and it worked!

1 Like