Not seeing the 2nd Harmony Smart Hub in ST discovery?

Last week I setup my first Harmony Smart Hub (Family Room) to ST and everything went fine. I also have it setup on my Amazon Echo to Turn On & Turn Off the Family Room TV.

So I just added my 2nd Harmony Smart Hub (Theater Room) on Logitech MyHarmony setup page. Both Family Room and Theater Room Hubs have Smartthings signed in, and authorized as a Device. Both are able to control everything on ST by going through the Harmony’s phone app with out a problem.

But, I have been trying all day to get Smartthings to discover the newly added Harmony- Theater Room Hub, but all it can find is the the Harmony- Family Room Hub (first hub added).

I would love to add the 2nd Harmony Hub to ST, just so I could add it to the ST SmartApps so our Amazon Echo and soon to be new Echo Dot would be able to control devices from that hub too.

Any info you could provide would be great to hear,


I have same problem, emailed support and got list of voodoo tricks, specific rebooting while hopping on one leg sequences, and try rebuilding everything from scratch suggestion. Will eventually try going through the list but for the work involved and lack of confidence I have in the solution probably not any time soon. Sorry couldn’t be more help. If you find the magic fix I’m all ears though :).

Login to your MyHarmony account and see if you have any inactive hubs. Like if you started with a hub and later on added a touch remote and paired the 2 together then you have the first device as inactive. This was bugging me for a couple of weeks but once I removed the inactive device all was well. You may even have to try re-logging in to the smartapp once you removed the inactive device. Also double check that you are on the latest software.

That’s the usual suspect.

No inactive hub on the harmony side of things.
Went into MyHarmony setup page and removed all devices, including ST from both hubs.
Then I went into ST app and started trying to remove the Harmony Hub (HH) in devices and any Activities (smartapp) tied to HH.

That was when I started having a new issue, ST wouldn’t let me remove any of the HH activities I setup (I only set up 3) kept telling me “Error… Cannot remove a device that is being used by a SmartApp”. So I click on the smartapp link and it brings me to were the HH was fist found in the Discovery tab. So I tried to remove the HH from that tab, but now it tells me "Device still in use. Remove from any SmartApp or Dashboard, then try again."
So I went though all my app that had access to my HH, which was Amazon Echo, and SharpTools and remove any access from them. But in the SmartApp listing I still see were it shows Logitech Harmony (Connected), so again I tried to remove it, but kept getting the warning that it can not be removed.

I tried and rename all 3 activities I setup in Harmony as “XxxNOT-USED-01xxX”, to see if I could find them any easier when looking for them hidden any where, but no luck.

I really hate to reset my ST hub and start over, after adding over 30 smart devices and creating apps in the developer tools webpage. But I guess I have all weekend to do it.

I now have everything working with out doing a reset. ST now sees both Harmony Hubs (Family Room & Theater Room).

What I happen to find was when I was logged into my SmartThings account ( under My Devices and looking at my Harmony Hub, it showed all the devices I checked off to allow the Harmony Hub to control through ST when I first set it up on the Logitech’s Harmony setup page. But I was not able to see any of that on ST app, so that is why I kept getting all the warning about not able to remove the HH.

So what I did was setup my Harmony Hub on Logitech website again and added ST as a device, but did NOT add any devices (lights, switches, activities) for the HH to control through ST, if there was a device that had a check mark next to it I removed it.

Now all this time I still have the Harmony Hub showing that it’s still there and Active, even thou it was physically removed from my setup. So now I went back to Marketplace again on the ST app and added the Harmony Hub and after a few seconds it recognized the HH again. I did not add the HH to anything just yet, what I did was go back and logged into my SmartThings account and now noticed the HH in My Devices has no devices actives associated with it.

So I went to my older 3 activities that I renamed “XxxNOT-USED-01xxX”, etc… and was able to remove them with out a problem this time. After I was finished remove anything related to the HH I went in and removed the Harmony Hub. Once the HH was remove so was the link with Harmony account & ST account.

Now with both Harmony Hubs (Family Room & Theater Room) set up for each room I added ST back, but for right now I did not add any devices the the Harmony to control via ST. I went back into Marketplace and added the HH, I now was requested to sign into my Logiteh account to link ST to it. Once I clicked done in a few second it showed it found my two Harmony Hubs and the 6 activities I created for them.

I was also about to connect the two Harmony Hubs activities (Theater Room - Watch-TV, Family Room- Watch-TV, etc…) To our Amazon Echo.

I hope this might help anyone who might have the same issue that I had. Hey @scottalex

Thanks again fo everyone who responded!


1 Like

Thanks David, I was originally resisting a rebuild since I have quite a few Harmony objects I’d have to cleanup/recreate. But you inspired me to bite the bullet. Once getting rid of everything and starting Harmony Connect from scratch, I too found both hubs.

@scottalex Glad to hear that you got it working too!

This helped a lot. I appreciate your input. I knew it was the smartthings apps having issues with getting credentials from harmony site. Didnt know how to work around it but this helps.

I cant find ST hub at all when adding it from harmony app -> home control, any ideas?

Remove all Harmony Activities, Hubs and SmartApp and start from scratch.

This thread will be of further help: Harmony (connect)