Not getting forum emails any more


(Mike Thomas) #1

Since late last week I am no longer getting any emails from this forum.

I have “Watching first post” set for several categories, then when I find a topic of interest I set that topic to “Watch”.

Did something happen to your email server? Or have I broken some rule? :grin:

Thanks … Mike

PS - I already checked my Spam folder


(Sam Saffron) #2

That would be cause our emails to your email address keep bouncing, I just reset the bounce score for your emails address.

Can you confirm you are using the right “gmail” account and not one you cancelled or something.


(Sam Saffron) #3

What we actually got back from gmail is:

This is the mail system at host mx-out-04c.sjc1.discourse.org.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<redacted@gmail.com>: host gmail-smtp-in.l.google.com[173.194.203.27]
    said: 550-5.7.1 [64.71.168.242      13] Messages with multiple addresses in
    From: 550 5.7.1 header are not accepted. g17si1595146pgj.222 - gsmtp (in
    reply to end of DATA command)

@zogstrip can you confirm what is wrong here?


(Crispy) #4

I’ve also noticed this behavior…I’ve stopped getting emails since around late Friday last week.


(Sam Saffron) #5

We have isolated that this is due to this user name, when we send an email on his behalf many mail servers automatically bounce it.

@tgauchat’s name is: “ActionTiles.com; SmartTiles.click; CosmicPuppy (Terry) GitHub: @cosmicpuppy ; Twitter: @CosmicPuppySF ; NOT a SmartThings Employee.”

@zogstrip is working on a fix.


(Morgan) #6

Yeah, I think this is affecting me as well. Is something going on ?


(Sam Saffron) #7

We have a bug in our mail handling code triggered by users with extremely long names with special chars in them.

We will fix the bug.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

Gosh… I feel really, really special now. :crying_cat_face:

It would be courteous, please, to not blame my “name”, but just acknowledge your lack of sanitization of input data.


(Mike Thomas) #9

Are you saying tgauchat’s long name caused this, or mine? (which is not very long at all)?


(Sam Saffron) #10

Sorry, this is absolutely a bug in our code.

But please be mindful that when we send emails on your behalf people will see a message from ActionTiles.com; SmartTiles.click; CosmicPuppy (Terry) GitHub: @cosmicpuppy ; Twitter: @CosmicPu which at best will be very confusing to end users.

Names were really simply intended to be names of people.


(Sam Saffron) #11

Your name did not cause this, its a bug in Discourse code when handling @tgauchat long name.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #12

Sure, … but the “long name” works great as helpful “mini-bio” identifier within the Forum.

May I suggest a feature request that Discourse provide separate inputs for “short name for emails” and “forum name”. Perhaps emails can default to either if the other is not available. Thanks for consideration.


(Sam Saffron) #13

We actually already have a special field for “title” that only staff can set just for that case. If smartthings would like any user to set any title, they could ask us to add such an option, but as it stands it is reserved for “badge titles” and “staff assigned titles” (like my discourse staff title)

I do feel, that it is incorrect and confusing to use user names for what title was intended for, but this is the smartthings forum and they are in charge, not me.


(Mike Thomas) #14

I can confirm emails are coming through again, thanks!


(Régis Hanol) #15

It’s not fixed yet… (un)fortunately, only notifications generated by @tgauchat are having this problem.


(Régis Hanol) #16

Ok, the fix is in and deployed here. Everyone should now be able to receive notifications from tgauchat.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #17

Unfortunately side effect to me:

All my “unread counts” for all Topics were reset. I have hundreds of posts listed as unread… Oh well… easiest enough to mark “all as read”, but I might accidentally miss something.


(Sam Saffron) #18

Ouch this does not sound right, I don’t know what caused that to reset, we will investigate.


(Brian Busch) #19

As a semi-related issue, I used to get daily activity summaries of this board which was great for me. I stopped getting those and I cannot find that setting anywhere. Was this capability removed with an update somewhere or am I just blind?


(Sam Saffron) #20

yeah it appears @slagle disabled digests globally ages ago, not sure why