No Cree Bulb Control for Google Home


(John) #1

Looked everywhere for a solution to this but can’t find anything. I am trying to integrate Google Home into my Smartthings. Smartthings was already set up and working perfectly. I have two ecobees and 8 cree bulbs. I set up my Google Home and it seems to work fine. I went to integrate ST. I followed the instructions. Upon logging into ST in the GH app, only the thermostats show up to be “authorized.” And afterward, GH has no idea what I’m talking about when I ask it to turn on lights. It controls the thermostats just fine.

I’ve tried unlinking and relinking ST. I’ve tried rebooting GH and ST hub. I’ve tried deleting all data in the GH app. I’ve tried leaving the cree bulbs on during integration, I’ve tried leaving them off during integration. I’ve tried some on and some off. I’ve tried adding a new bulb after integration. I’ve searched in vain through every setting in both apps looking for something I’ve missed. Everything has the latest update.

Exasperated…


(Realy Living Dream) #2

Did you authorize sharing the bulbs in ST ? Ecobees are connected directly with GH not through ST.
Open the GH app in ST, click through & it will open an IDE window where you choose which devices you allow GH access to.


(John) #3

Thanks for the reply. Yes, that is where I see the two thermostats but the light list is empty. I’ve let it sit on that page for 30 min or so thinking it was taking a bit longer to “see” the lights but to no avail.


(Realy Living Dream) #4

In the IDE it will list every device on your hub. If it it not showing than you are not on the right page, not connected to the right hub.

Open Google Home app, click on Home control , click add devices, then click on Smart Things/Samsung connect

Click on check for new devices.


(Realy Living Dream) #5

Sing into your ST accont on the next screen and you will see this
Select your hub from the list in drop down


(Realy Living Dream) #6

Check off all he devices you want to be able to control through GH


(John) #7

Looks like I was doing it correctly. I only have one hub. Here is my ST devices page and here is the IDE that google home pulls up.



(John) #8

Solved. Somehow I had 2 smartthings accounts. Switched to the correct one in the Google Home app and now everything works. Thanks for your help.