No choice to add echo

I was instructed to add amazon echo as a thing on my ST app. When i go to voice control, the only option i have is google home. Any ideas?

Try again after this is resolved.

Also, did you try to add the ST skill in your Alexa app?

Ya, the ST skill has been added.
I will keep an eye on that uodate though.

I’ve never seen Echo / Alexa / Echo Dot etc in the Voice Control tab to add. Who told ‘instructed’ you to add it?

It’s a new option with the most recent update, I think.


We were working on another issue i was having.

Mine says it’s version 2.4.1. What’s the latest? I went to the play store and no update available

I’ll flag the issue with the missing Alexa entries, should be a quick fix.

However, you can’t actually initiate the process from that entry and you’ll want to set it up from Amazon’s end. See for more info. Also you’ll want to wait until Amazon’s issue is resolved. :slight_smile:

1 Like

I’m running 000.017.00012 on android and am also not seeing the option to add an Amazon device. just for some more feedback.

Mine is up now.

1 Like

Thanks for the data point. The marketplace is mostly independent of the Hub firmware and app.

I flagged this issue and it should be showing up now. If not, let me know!

1 Like

Should i be able to access anything through this…

Other than this…

I was told to look for this screen and can’t find it.

If you toggle “Allow Alexa to access all devices and Routines” you can select individual switches, thermostats, and locks.

Ah, gotchya. So if i leave that toggled “on”. Alexa will have access to everything by default?

Correct. :smile_cat:

Ok, thank you. I must have other issues then.

Now that you have the smartapp loaded you may need to discover your devices again. If that does not work get back to us on the fan thread.