New version SmartThings App Z-wave repair issues

I’m new to SmartThings but not at all new to Z-Wave.
I previously used InControl, which changed to Axial Control, running an Aeotec Gen5 Z-Stick.
This spring I purchased a new Aeotec Smart Home Hub (SmartThings V3). Recently I spent 10 full days migrating most of my (approximately 75) devices to the new HUB. I ended up with about a dozen (mostly older) devices which either wouldn’t join or wouldn’t work properly afterward. I still have a few devices I need to replace with newer.
As I added devices, I would periodically run the Z-Wave repair function from the SmartThings app. Unsurprisingly, the more devices I added the longer the repair process would take. Currently it takes about 30 minutes to complete.
Unless I am very diligent, my iPhone often goes to sleep on me before the process completes.
In this situation the phone app never indicates that the process has finished.
I have 2 questions as a result.
1, Does the repair process actually finish when my phone goes to sleep.
2. Assuming the process does finish, where can I go to see any repair messages and to verify that it did finish successfully?
Most of the articles and discussions I find usually refer to the IDE and/or the classic App. I don’t have either of these.

You can do a Z-wave repair using the Advanced Web App under hubs. Samsung account

I just tried that.
The Z-Wave repair in the Advanced Web App under Hubs doesnt provide any feedback at all.
It did run because the system was unresponsive for about 30 minutes. But the web never even indicated that it started.
Oh well, the repair isn’t solving the problem I was hoping to fix, so I’ll post elsewhere in this forum about a device that vanished overnight.

why are you doing so many Zwave repairs ?, i think i have run mine a handful of times in 5 years, i add and remove stuff all the time, no issues anywhere… actually, thats a lie, i get issues like everyone else but they are not hop related

Your older devices, what are they ? if they fail to join have you searched for a relevant driver or asked if a fingerprint can be added ??

The old app was deprecated maybe 4 years ago now and the IDE no longer exists with relation to Smartthings connections, that is why you do not have them, they simply dont exist

Best practices on most of zwave platforms is to run a repair once a week. Some systems even are set up to run it nightly. It should be a “can’t hurt, might help“ kind of thing, based on the independent third-party standards.

However, multiple community members have reported that smartthings support has told them they should not be running frequent zwave repairs. I can only assume that has something to do with the cloud portion of the smartthings architecture, it’s certainly not a typical industry recommendation. :man_shrugging:t2:


There is always a best practice and if you are getting dropped or instable results then yes i agree but if you are adding devices that are in situ and had previously worked then chances are all is well with distances and connections, if removed to be reset then they are a new device, if they fail to add likely reason would be a missing driver/fingerprint not poor signal

I was doing a lot of repairs because many of my devices would not join on a network wide inclusion.
My solution was to join the devices in close proximity to the hub, then move them to their real home. Things would get real wonky and I would run a repair to make things responsive again.
It has been a real chore moving close to 80 devices out of my old system and into the new hub.
Part of the issue is that my system grew over time from a couple of switched outlets which were intended to simply force a remote restart of a couple connected devices.
My other issue is that this system is at my cabin where there is a cabin and three outbuildings pushing the distance limits of the early Z-Wave devices. As a result, I have added several devices at intermediate locations to strengthen my mesh. It works reasonably well and has gotten better as I have replaced many of the original devices with Z-Wave Plus devices.
In hindsight there would have been better ways to go about this, but I have so many devices that it would cost a fortune to switch to ZigBee or some other solution.
Once I get everything moved over, I don’t expect to do as many repairs.
The repairs do seem to finish, there is just no way to know if there were any errors or not.
I just start a repair when I don’t expect to need any automation for a while, such as when I go to bed or start the 4-hour drive home.
Thanks to everyone who took the time to reply!


One thing that has worked for me for those problematic zwave devices whenever i move them across between environments and will not pair is i put any of my zwave hubs in exclusion mode and trigger the pair button on the zwave device. This can be done on any zwave device even if it isn’t part of your network such as orphaned devices. This process cleans up or completes the exclusion process just in case it wasn’t done correctly previously.

At minimum you should be able to include it again as a basic device using Samsung drivers. From there you can attempt to find better edge drivers

1 Like