New to app, issues/questions/hate to make yet another topic

So got the banner obviously and after 5 years of classic app usage I switched. So also I dont use the app hardly at all, I believe in automation not control. So yea dont care too much but having issue since the conversion to my account.

First few things. I keep my stuff as stock as possible. No custom DTH’s, no custom apps, everything by the book. Only stuff from the ‘marketplace’ in the old app until now.

First issue is with minimotes. Their device info has 0 in it, totally blank. In the old app it just had listings for the 4 buttons. But the minimote had a blank device page now. This doesnt affect much just something I noticed.

Scenes. So I’ve had my ‘Goodnight!’ Automation (think the old app says this is a Routine tho but its in the Automation tab) forever now. It said it migrated. So like everything else has worked so far in testing. I assume this is now a scene cause thats where it is its not under Automations. But ok i try to trigger it with the minimote last night going to bed, nothing happened. now other buttons do work, like turning on all the lights in the bedroom or the dining room fine. So i go into the scene and touch it to run it, says fails for “unknown device”. I edit the scene and do ‘test’ and it works. I create a new scene with same functionaity, turn off all my lights/outlets and set mode night, same ‘unknown device’. No clue what device. Or is this a limit, I’m not sure how many things Im turning off, maybe 30 or more. Last time in the old app when i tried to set a scene up with lot of lights it failed, but that was a year or two ago when scenes were new. How to troubleshoot this?

Mode needs to be visible somewhere in stock form…this is more or less unacceptable lol. Like night, day, tv watching…dont people use modes to be able to have different reactions to inputs based on that mode of the house?

It now looks like i have 2 iphone’s listed as presence devices???

Do I still go to the accounts ide login page, cause it says its the groovy ide still…but i know this stuff is changing. Ive honestly not had to do much work to my setup in a year or two other than batteries. I have like 4-15 things in every room of my house so its not like Im a super basic system, i just try to keep it very ‘by the book/stock’ and its been very reliable actually. so this change actually throws lots of wrenches in my monkey. Awaiting friday when I go grocery shopping to see if mobile presence works or not…

1 Like

I’m seeing the same thing. It used to work :frowning:

Upper right menu > manage location. You can view and change it here.

This isn’t uncommon. Try to see which one is working and delete the other from the IDE.

yes, for now.

2 Likes

Also possible the migration created a new presence for the new app and they still have one for the Classic app. Doubtful but who knows.

1 Like

Ill delete the phone friday or saturday after i try auto arming of the smart home monitor whatever its called now.

The “unknown device” error is the main snag tho. What would cause a scene that is set to turn off every light in the house and set mode fail? Is there a limit of devices in a single scene?

Also, this app is slow as puddin… I can open the classic app, go to a room and turn on a light 3-5 seconds faster than doing similar in this app. Or even just using the shortcuts on the home page, since its doing a refresh of all the items/states it seems.

Re thinking a bit…maybe i dont want a ‘scene’ of turning things off, but an automation. Going to try that tonight.

1 Like

Ok tried thinking different last night. I will say that for anyone that was used to the classic app, used it for the past 5 years, and possibly have had a well working automated home that you rarely had to make any changes in the app in 2+ years… relearning something new is not trivial.

So previously my 'Good Night! in the ‘Automations’ section on the old app turned off (think i saw somewhere 53 lights/outlets) and set mode to Night. This was how it has been for 3+ years at least. This worked well, and actually fairly quick. Button on mini mote to trigger, and it would turn all those lights off in say 3 seconds.

Now tried to do that with a ‘Scene’ in the new app. Since thats what the new app said ‘Automations’ in the classic app were transferred to. Well I know that scenes in the classic app have given me trouble in the past (I still think theres a limit of devices or changes or something that isnt told to you). Well that transferred automation into a scene did the ‘unknown device’ error and not do anything at all. I created one that had the same stuff in it on the new app and still same issue.

So tried making an automation, if mode changes to night, then turn off all the lights. Then used the minimote to trigger mode change (forget if im doing that or running the scene which just changes mode). But doing it via automation worked, but slower for sure. That took 5+ seconds for it to loop through all the devices and finish.

So thats one ‘issue’ solved I guess. Still that I had to do anything post migration is a lack luster experience. For having a fairly large install, that honestly I havent touched other than batteries for the most part for 2 years…to have to now spend a few hours or more getting back to there and also having to learn a whole new method of thinking about automations sucks. I know the existing customer base (or the old guard at that) is now less than 1% of the install base of ST…but Id say most of us have spent time praising ST and just keep getting smacked in the face. I know I am really considering a HA install these days…and Ive been very happy with my setup. Every room of my house is automated but the bathroom. I like my setup, its been maint free…but now I have to spend 1-2 hours over the next 5-7 days redoing this I bet.

1 Like

The new app is so slow too. Not sure if its cause its forcing status refresh of every item when you open the app or what…but its slow. Maybe for standard customer its fine, but Id say I have to wait 10+ seconds before I can actually control a device. Some will say ‘awww 10 seconds just flip a switch’. Its the fact that i open the app, see the button, tap it…(all this fairly fast actually) but then because everything is refreshing nothing happens for easily 10 seconds.

In the classic App when the family member/phone would be back, the routine notification would be Performing “I’m Back!” because “Iphone A” arrived" and the new app notification is “Someone is Back arrived” … no mention of which member/phone… Any suggestions how this can be corrected/implemented in the new App?