New Sony Bravia TV integration for 2015 - 2016 alpha

Hi,

My TV is a Sony Bravia_ATV3_4k_EU - KD-55AG8.

Everything except the power control works perfect. I cannot get smartthings to poll the device correctly and show the tv as being on or off. It always just says off.

I’ve copied and pasted the device id into the device handler network id, but still no look.

Any ideas?

Really appreciate this work, thank you.

Hi. I have a Bravia KDL-55W700B. I was trying to connect it to my SmartThings app but got as far as the static ip part and became completely loss. Is this not for us tech dummies because I can only do this if I have step by step. Thanks

Just noticed your screenshot from the “new” SmartThings app.
How have you got the TV to show on it ?
Mines working fine on the old app but if I go to the new one it shows offline and says network or server error if I click on it.
Are you using the original device handler from the 1st post or have you modified it at all?
Thanks

Hey Steveuk23,
I didn’t make any modifications to the original device handler - used it as is. If it makes any difference the “New” SmartThings app I am using is version 1.7.36-23 on Android.

I rarely use either app anymore - I’ve gotten too lazy and use Alexa voice commands for just about everything now.

Thanks

Cheers mate
That’s weird then I’m on the same Android version and handler but mine gives me a network error message even though I can see it’s reporting as working behind the error message.
Like you I don’t really use it at all on the apps only in a routine to turn on and off lol

Hi,

So first off thanks for this. I’m almost there.

All of the buttons work except on off.

I’ve went into the device in the samsung IDE and changed the ip address to hex. All i done there was to press a button, copy the address from the live loggin screen and paste it into the device in the ide.

Any ideas on how to get the on off part to work?

Thanks

Thanks for the DH. My tv KD-49XD8005 from 2016 is working with it. The only issues are that the classic and new apps don’t show when Tv is on or off and I can only turn it on through them. On the other hand Google Home app can turn it on off and shows when tv is working or not. I have ST hub v3.

Has anyone got the on/off status update to work without having to hit refresh? I have an x900E that has this problem.

Using the method in the first post to set device to a hex decimal converted ip…

Yea my device network id is set to the hex version of the ip. I can control it, but it doesnt update. Should it be hex in the actual device settings within smartthings or just in the device handler?

It works for me, but it typically takes 5 to 10 minutes before the status is updating in ST…

1 Like

Gave this a try on a bravia KD55XE8596 but unfortunately didn’t work. Seems to be able to to recognise the device and send commands but none work. Also, the ui doesn’t work for the new Smartthings app.

Scrap that, it works! But I didn’t have to convert the ip to hex.

Hey all. I’ve managed to get this working with my Sony XE80 TV in the new smarthings app (for the purpose of turning the TV on and off). However I’ve noticed the power status doesn’t update unless I open the device in the app and refresh the page or wait for a few minutes.

Reading through the comments I see its mentioned to set the network ID to hex which I have done.

Is there anyway of initiating a quicker refresh. Thanks

Hello, I’m using your DTH on an x900f and everything is working fine except for the power on/off and power on/off status. I made sure to follow the directions in the first post and set my IP address however I’m still not getting on/off control or status. The funny thing is that it appeared the status was showing properly before I set the IP.

Any ideas on how I can get it to work? I’ve tried to press the refresh button a few times but it’s still not updating.

I have the same issue. Any idea how to solve it?

Dave,

I have the same menu as you on my Sony TV. Did you get yours to work or are we doomed to fail??

Mine is not auto updating anymore, it requires me to use pollster… I haven’t seen any feedback from @steve.bratt and not sure if he has any additional input.

Also seeing VERY slow status updating at the moment…
And noticed that the “update” button found when opening the device lost it’s icon. (round arrow)
Could that be a coincidense…?

I have tried the device handler on a ST v3 to control a KD-55XG8196 TV. The function on/off doesn’t work. Do you have any idea what could be the problem ?
Thank you

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.