SmartThings Community

New Sony Bravia TV integration for 2015 - 2016 alpha

dth_av
(adam) #365

/I have a XBR65X850F which is a 2018 model. Anyone know if this will work with it, have not been able to get it yet.

I also have a XBR55X810C from 2015, and I cannot get that to work either. I feel like every setting on the TV and IDE/App are correct.

0 Likes

(Steve ) #366

If you’ve got the settings on your TV to do it then can’t see why it wouldn’t work.

0 Likes

(adam) #367

I cant for the life of me figure out why I cannot get either TV to work. I even tried a hardwire. It just doesnt recognize it in any way. How can I confirm the port?

0 Likes

(Steve ) #368

You see it in the settings on the TV if I remember right.
Have you got the Smartapp installed

0 Likes

(adam) #369

Which Smartapp? Maybe thats what I am missing? I have the DTH.

0 Likes

(Steve ) #370

Ha ha yeah forget that it is a DH it’s me getting confused it was over a year ago when I did mine.
Can you take a picture of each setting you’ve changed on your TV and a screenshot of your settings in the device configuration page.

0 Likes

(adam) #371

I also tried running the POST command through Chrome, and I get this raw response: {“error”:[5,“Illegal JSON”]}

0 Likes

(adam) #372

@pmjoen @steve.bratt
First off having read this entire thread, thanks for the hard work. Was wondering either of you could give any further insite to my issue I posted screens above. Im getting {“error”:[5,“Illegal JSON”]} so I feel like its communicating but having an issue that I cant figure out on my 2018 nor my 2015 TV. Both seem to be on Android 7.x

0 Likes

(Steve ) #373

Sorry I didn’t receive a notification about your reply :frowning:
Try setting your psk key to “sony” like mentioned in the first post , not sure that would make much of a different but best to check.
Also have you entered your IP as Hex in the device settings on Agathis m SmartThings IDE?

0 Likes

(adam) #374

Yeah after I add the IP, I go back to the logger and copy the hex and put it as the Device ID.

What is most confusing is its not specific to just my 2018 TV, but my 2015 as well. Both give that same JSON error which makes me think there is communication but either a setting is wrong on the TV, the port is wrong or something with Android 7.x is an issue?

0 Likes

(Steve ) #375

Is your router and TV on the same subnet ?
Have you tried pinging the IP to see if it responds?
I’ve just checked my TV settings and menus and they’re exactly same as yours and mines set same as yours besides my psk saying Sony.
Also what does your hex address look like in the device network ID.

0 Likes

(Steve Bratt) #376

are your tv’s wired or wireless? some routers block wifi to wifi communication as a feature you can disable for security purposes. i think the tv responds better when using a wired network

other than that i cant offer too much help

0 Likes

(Glen King) #377

A semi-related note; these TVs were, at some point, supposed to be updated to work with Alexa. I’m sure any of you looking on the market at new TVs have noted that Google Home is what is being provided instead. So my dream of being able to say “Alexa, change to Channel 12” is dashed.

OTOH, if you can say :hey google, change to channel12” that’s just as good - even if a bit confusing for those of us who are all-in on the Alexa ecosystem.

0 Likes

(Blair Pollard) #378

I am unable to get this to work at all set up the device handler added a new device set the network I’d with the one the app made when entering in the details. Set all the settings correct on the TV.

But absolutely nothing works no buttons on or off doesn’t work. I get no errors in the use log and trying to do the rest web thingy I just get 400 bad request

0 Likes

(Steve ) #379

Did you put the device ID in and then enter the IP address into the device settings on the SmartThings app.
Check you have converted the IP to hex correctly.

0 Likes

(Brigidino) #380

Do you think guys i can merge it for Philips android TV also?

0 Likes

#381

I am a beginner to all this really so please be gentle. I cannot get this to work at all. I have installed the custom device handler and set a static IP address on my router, set the PSK key etc but when I try to add a thing in smartthings classic app nothing shows up. My live logging never shows anything with regards to sony bravia TV either. Any help would be greatly appreciated. I have a Bravia KD-49X8505B

EDIT: I have got this working after much scratching my head about what I was doing wrong. I was looking to just add a thing rather than create a new device in the IDE which I was unaware I could do. Looks good so far.

1 Like

(Ram) #382

I have XBR 900E and setup everything in the post 1. The problem that I have is, the TV status is not getting updated at all. If I go the mobile app setting and hit the save button then the TV status is updated then I can turn ON or OFF once then it goes to dead mode. I have to hit the save button on the mobile app setting to get the current status.

I don’t know what could be the problem. Anyone come across something similar?

0 Likes

(Ram) #383

Ok, I had to hit the refresh button to get the latest update. Is it possible to refresh the status for each action is completed?

0 Likes

#384

I’m also having this problem and the only way round it I can find is to set up a piston in WebCORE that refreshes the device every two minutes. I can’t test it out though as I’m away from home.

0 Likes