New SmartThings Schema Integration for Arlo

Does anyone at SmartThings care about the visual cosmetic difference with how the SmartThings app is displaying various Siren devices in the SmartThings app? The picture is showing two different Siren devices when everything is normal and these Siren devices are both Off, but as you can see, the Arlo Base Station Icon is different from the Zigbee Siren Icon, and it doesn’t show the status as Off like the Zigbee Icon does.

1 Like

Well, they apparently added ‘Sound’ detection at some point recently since I just had SmartThings report that there was ‘Sound Detected’ on an Arlo Camera. I don’t know if it requires that the Arlo app Armed Mode Rule for ‘Detects Audio’ needs to be selected to report Audio Detection to SmartThings, but that’s how it was set when I received it in SmartThings.

1 Like

The 6 hour periodic check does not seem to be working over the last few days for me. I’m using the Device Monitor SmartApp set to 6 hours which has not reported anything in months until it started a few days ago. Even after I’ve turned On/Off the Arlo Cameras via SmartThings multiple times a day. Also, the Arlo cameras do not appear offline in SmartThings. I’m able to control them, and even stream video. It’s just the Device Monitor SmartApp is now reporting that the Arlo Cameras have not reported in over 6 hours. I have to open the linked service to run the background state update to get the refresh/update state to run and then the Device Monitor SmartApp is happy and reports that they are online and reporting again.

Since I control the On/Off state of the Arlo Cameras with SmartThings, I have not yet tried turning a camera On/Off in the Arlo app opposite of the SmartThings setting to see if the cameras state is updated in SmartThings within the 6 hours state update window, but I’m testing that now.

@shravan, I waited all day and 12 hours after I turned On an Arlo camera in the Arlo app, the SmartThings app still shows that it’s NOT On. So, the 6 hour periodic check is not working at all for me.

It seems that every morning the Device Monitor SmartApp reports that the Arlo cameras are reporting, but 6 hours later they aren’t. So, it looks like the 6 hour periodic check is now happening every 12 hours apparently.

Ok, for some reason everytime I go to my camera device on my smartthings app I get a notification that says we’re having trouble connecting. Check your network connection and try again. I have 2 arlo pro 2 cameras and it just will not let me open the camera and look at the cameras or do anything with them as of right now. Idk when it started doing this but i have deleted the integration and added back and that didnt work. Has anybody had this issue before with arlo and smartthings integration? Any feedback would be greatly appreciated.

Hi all, my apologies on advance about asking whether Arlo’s modes can be changed by SmartThings. I’ve already looked at multiple pages of previous replies and excellent input from the SmartThings tech folks. I probably missed a later input on this, but the only input from SmartThings I could find was by arlo_eng: Adam Developer in Nov 2020: “Right now, mode control is not an available feature in the partner integration. The intent is to drive it via automations. But it may be something we can explore in the future”

Like a couple of others who requested this capability (which was in the original implementation of this integration), I’m OK with interacting directly with Arlo to manage its modes. As a work around, one of my SmartThings’ automations turns on an arm Arlo virtual switch in SmartThings when I leave home, and turns it off when I return. IFTTT then arms or disarms Arlo directly, depending on the ‘state’ of this virtual switch.

I’d prefer to minimize the number of moving parts, and would like to accomplish this just with SmartThings and Arlo, and eliminate the IFTTT middleman.

I would very much appreciate any response whether this capability has already been provided (and how to access it) or whether it’s being considered / will be soon released.


Here’s what I’m doing since the Arlo cameras won’t do anything no matter what Armed mode is set in Arlo app if the cameras are turned Off.

I manage the cameras On/Off state from SmartThings. I have two different Arlo app security modes setup in the Arlo app. One for Armed Stay, and another one for Armed Away. I then use the Arlo app’s Geofencing mode to manage which Armed mode is active in the Arlo app. So I have different camera setups depending on if I’m home or not. I just leave the Arlo app in All Armed Devices since I have SmartThings Automations ‘Turn On’, or ‘Turn Off’ the specific cameras depending on whatever security mode the STHM is in. When the STHM is Disarmed, then all cameras are turned Off and the Arlo Geofencing has Arlo in the Armed Stay mode that won’t do anything since the cameras are Off. When the STHM is in Armed Stay, then just the outside cameras are turned On while the Arlo app Geofencing has the mode set to the Armed Stay mode. When the STHM is in Armed Away, then all of the cameras are turned On while the Arlo app Geofencing has Arlo in the Armed Away mode.

As for STHM Armed Stay though, I also have an Automation so that if any multipurpose sensor Opens when the STHM is in Armed Stay mode, then the Automation will Turn On all of the rest of inside cameras too.

I am wondering if the silent mode on Video doorbell is available for automation. I cannot find this setting when I create an automation for Video doorbell?

@shravan Do you know if there are any local edge integrations planned for Arlo? Maybe something based on button presses or motion with the Doorbells? Glad to see the integration growing, but curious what it will look like in the new “Matter” world and Edge.

@shravan can you please share if the silent mode for the Arlo doorbell is being considered for automation?

1 Like

@shravan, @arlo_eng, the 6 hour periodic check has obviously changed to 24 hours since SmartThings never updates the Arlo camera status when the change is made in the Arlo side since SmartThings doesn’t show the change until the next day.

Is there any support for original Arlo cameras (VMC3030)?

After going through the steps involved in submitting this through samsung support, and having them tell me at several steps it should be working, I finally got some closure…

We do apologized for the delayed response and would like to inform you that we were able to look into this issue. Unfortunately, Arlo has chose not to support the on/off feature for the VMC3030 cameras in their updated integration on the SmartThings platform. Please reach out to Arlo for support for any additional information and feedback. We apologize for any inconvenience this issue has caused.

That said, the current integration allows power control through the smart lighting app, so I am not sure why they would not fix this?


EDIT: And now I have reached back out to Arlo as instucted in Smartthings response, despite being told by Arlo to contact Smartthings. Seems like the truest definition of insanity…

1 Like

I do not see the Arlo Chime listed as a supported device. @shravan The chime would be excellent to use as a notification device and/or siren within SmartThings. I can see cases for it to be integrated to the Smart Home Security app or simply with automations. Any plans to add it as a “siren”?


I have just added a Arlo Pro3 Floodlight cam to Smartthings, and everything vent smooth.
I can not however do an automation, that only enable floodlight when motion in “armed stay/away” status in Smartthings. I have several options like Strobe, Sirene, Strobe & Sirene… but when choosing Strobe all it does is turn on sirene when motion.

I can not see this issue being answered anywhere. Do anyone know a solution to this issue?

Hi @shravan I am trying to add the Arlo Integration and I am getting an error “Connection between SmartThings and Arlo encountered and error” Request Code:…

Can you please help me understand what the issue is, and how to fix it?


@suddin I’m having this same issue, has anyone provided any insight? Were you able to resolve it and if so, can you share what steps you took? Thanks.

Piling on.

I have a VMB3010r base station with a number of older H11 cameras. I’ve had the integration with ST working for years, primarily triggering motion notifications in ST while using Arlo to control the cameras. Around December 23, the motion detection suddenly just stopped working in ST. Arlo, of course, recorded, the devices were still in ST - the trigger notifications just seemed to STOP.

I found this thread and thought that perhaps the shift in schemas suddenly caught up to me? So I removed the cameras from ST, deleted the integration to Arlo, did a bit of cleanup in Arlo (camera names, etc), and redid the link between Arlo and ST. I receive the same error as above.

If I go back into the settings in ST, look at Linked Services, select “Arlo”, the Host and cameras show up.

I go into Pistons, reselect the correct physical devices to link the camera motion triggers properly into the code.

…. And nothing happens.

BTW - When I perform the link, the SmartThings mode is not established in the Arlo app. I’m assuming that is supposed to happen?

Any thoughts?

@smacphee I also don’t see the SmartThings mode in Arlo. I do recall having seen it previously, but I can’t say for sure if/when it disappeared.

As for the cameras working with ST/webCoRE, I can’t help much here as I’m not using them for your use case. For what I use them for, they are reporting properly to ST/webCoRE and working properly.

Sorry, not much help here.

Most Arlo functions/events no longer work in ST. None of motion detection or doorbell press work now. Only Live view works, that’s all. Unlinked and re-linked the Arlo account did not fix it.

I had the same issue with connecting Arlo to Smartthings, the fix was to put all my Arlo modes to ‘Disarmed’ in the Arlo app before linking them through the Smartthings app.

I’m still having the issue of motion events from Arlo cameras not registering in Smartthings like @xiixexe mentioned.

I am having a similar problems as the last couple of posts. About 1-2 weeks ago the Arlo motion trigger isn’t working in smartthings. It had been working well for several years. I deleted the service in smartthings, removed all arlo references in smartthings using IDE. Deleted all routines and automations using Arlo motion, Reinstalled the service in smartthings and re-did the smartthings automations for arlo motion, and everything worked for about 8 to 10 hours now nothing is working is smartthings again. Arlo still senses motion and records video. It just doesn’t link to smartthings for the motion trigger.

1 Like