New Ikea tradfri Shortcut Button?

Well after 9 months of not being able to get my Ikea Shortcut Button working with SmartThings I was finally successful using iquix’s Zigbee Button edge driver.

1 Like

Good to hear. So many have had problem with it. I managed to pair it after few tries and it has worked ever since. I hope battery runs forever so I don’t have try to re-pair it ever again.

@Sakari @jamesrskinner does yours run locally or are the running in the cloud ?

All Edge drivers run locally as far as I know.

3 Likes

@Sakari how can i add iquix’s edge driver to my hub without any link ?

And the ikea short cut button, the held function does it run before release or do you need to release before it triggers the held state ?

Sorry for all my questions i am new to the smartthings community and home automation :sweat_smile:

@DJFliX has driver for this device in his channel. Here’s the link SmartThings. Add a little smartness to your things..

Enroll to the channel and install driver. Remove device first. Then go to add device, scan nearby and put button to pair mode. If not found just keep trying and trying. Eventually it should be found.

What come to releasing and pressing I’m not 100% sure because I only use it as a single press button.

3 Likes

Thanks for mentioning me! It’s nice to see that stuff that I try to hack together for myself also benefits others :grin:. In terms of battery level: I’ve paired my decide at approx 35% when I published my first edge driver (which would be 12 days ago) and it’s currently sitting at 30%. So I’m pretty sure this isn’t the worst result but it isn’t great either.

I do see the pressed and released events in Logcat so I’m fairly confident that they should work. However I have had no use for them so far.

Also I think it’s fair to mention @iquix here since it is basically his driver (and for that reason I left the copyright notice intact)

1 Like

Good point.

And the ikea short cut button, the held function does it run before release or do you need to release before it triggers the held state ?

To answer your question: on a driver level: yes. But in smartthings: no. It seems like SmartThings does not facilitate triggers that keep firing while the button is pressed. I do see the held event being generated when I am watching the device with logcat. There might be a way to emulate it, but with the current driver as it is, it is not possible yet.

Edit: As mentioned by @yotiko below: you can not use the held event in the SmartThings app. So while the logcat for the edge driver does output the correct events they will not be usable as such within SmartThings. I’ve edited my message to reflect this. My original message:

Oh, yeah. To answer your question: the held event is emitted as soon as the button is held. As soon as you release the button a release event is emitted. So you can use the held event to do stuff while the button is held.

1 Like

@DJFliX
Whoaa perfect :grin::smiley:

Echt bedankt voor jou werk :grin:

I now tried it.
This is what i see.

And held even

thats not going to work because smartthings only recognized the held event after releasing the button. And i even tried it didn’t work

Butt the push event is now faster :smiley: thanks for that :grin:

And its execution is in the cloud not local

As with other IKEA buttons, it depends on the integration. The buttons report held after a short delay and the stock Ikea Button DTH uses that for the held event.

As I am hit badly by the battery drain issue I don’t have my Shortcut Button installed, but if I remember correctly @iquix uses that report as a hold start and waits for the release. Whether the held event is sent then depends on the length of the hold (there is a maximum as well as a minimum).

I still have an On/Off button on SmartThings using the DTH and it seems to me the hold period has been longer since I updated the button firmware.

The IDE works in the legacy ecosystem and only really understands Groovy DTHs and the local handlers in the hub firmware. It remains useful for those. Other integrations are just represented by ‘placeholder’ device types. So it doesn’t truly understand them.

For the current ecosystem you get better mileage from the apps, the CLI and direct use of the API.

1 Like

Thanks, it’s helpful. I managed to get button online. Single click, but much better then dead hardware. :wink:

1 Like

Thanks man!

Hello all! As you can see, this is my first time here. :grin:
Because I’m new to this whole “DIY home automation” I bought a lot of gadgets, and like many others, I’m having a hard time pairing an “Ikea Tradfri Shortcut Button” to my Aeotec SmartThings V3 Hub.

First of all, I have two identical Ikea Tradfri Shortcut Buttons (you will see why this maybe matter in a little bit).
Let me give you some detailed steps of what I did (and in what exact order) and where I am stuck at the moment:

  1. I tried to pair both buttons to my hub like any other device with no luck.
  2. Googled around and found out about DTHs, googled more to find out what they are and how they work (repeated this for the IDE). Then I stumbled across this beauty: New Ikea tradfri Shortcut Button? - #33 by iquix (btw, thank you @iquix for this!) and added it into my IDE.
  3. Added my first shortcut button, got recognized as a “Thing”, went into IDE, and set the type to “Ikea Tradfri Shortcut Button” then BAM! - working like a charm.
  4. Tried to do the same for the second shortcut button… not so much “bam” sadly. Tried a few dozen times, but failed to work every time…
  5. Tried all that “Zigbee Button” mumbo jumbo with no luck.
  6. Learned about Edge Drivers because of @Sakari (thanks!) and enrolled on this SmartThings. Add a little smartness to your things. (thanks @DJFliX) then installed the “IKEA Shortcut Button” driver.
  7. Deleted the button from ST, readded it by using the “scan nearby” function, got detected as the correct type, got excited, went to test it… fail!
  8. Went into the IDE and saw that the new “IKEA Shortcut Button” that I just added, has the type “placeholder”, and for the “Zigbee Id” and “Device Network Id” fields I see no values.
  9. Got stuck… (<- I am here now, please help me to get to step 10: Success!) :cry:

Do you guys think that this might happen because I already have another shortcut button paired?
To be honest, I’m afraid to unpair the first button because I might not be able to pair it again.
All I want is to have them both paired (with DTH or Driver) and work for press and hold.
Is it too much to ask? :frowning_face:

1 Like

The IDE was not made for Edge or c2c devices.
Edge devices are always listed as placeholders, and most other field are blank. So what you are seeing in the IDE is normal and correct.

1 Like

Thanks @Paul_Oliver for the clarification!
I tried again a few more times today (with DTH and with Driver), but no luck …

Here’s a stupid question: do I have to add a new DTH for every button?
I’m thinking no, but I don’t get why the second button it’s not working since the first button works like a charm.

What am I missing? :slightly_frowning_face:

You only need 1 DTH or Edge Driver for each group of devices that are the same.

1 Like

Just noticed something odd in IDE, the difference between the first button (that works) and the second button (that does NOT work) - maybe this info is useful somehow:

Note: I removed the non-functioning button. Uninstalled the Driver, unenrolled my Hub, and added the button again using @iquix’s DTH.

image

Is this “Unknown Route” a common issue to fix?