New Hue lights not being added in ST


have 2 Hue hubs with several lights connected to ST. Just added some new lights to the Hue hubs but the new lights don’t show up in ST.

Tried ”add new device” and ”search nearby” in ST - but lights don’t show up. Also tried rebooting the ST hub + Hue hubs.

Using v2 hub.

Any ideas how to resolve this?

  • reboot your router also
  • scan nearby
  • look near the bottom of the dashboard to see if they were added in the “not in use” section

Thanks for the input. Tried rebooting router as well, but still no new lights.

Checked IDE but they lights don’t show up there either.

Will try another round of rebooting the hubs.

Resolved! Went through the add device type (selected Philips Hue) and the lights where added.

Earlier ”search nearby” used to work, bot not this time.


Thank you for this! I just added 2 new Hue white bulbs to the inside of my garage, and wanted to control them with ST to turn on/off based on a motion sensor. I looked everywhere in the app for a way to add them for about 3 hours this morning, then finally found this post. Solved the problem in about 15 seconds after reading this!!