NEW Hub Replace Feature for SmartThings Hubs!

Thanks for the reply!

Select the wifi hub,
select “Use Smartthings Hub”
Select “MANAGE SMARTTHINGS HUB”
Select top right menu (three dots)
See Edit / Remove / Driver / Replace / etc

I’ve gotta believe this is the software misleading you.

The way the feature was described it’s necessary to have a firmware version 0.50.xx for it to be capable of creating the backup file in the SmartThings cloud. Without that there is nothing to restore to the replacement hub.

I have no idea one way or the other, but it wouldn’t surprise me if this feature becomes available on the models which are also Wi-Fi mesh routers earlier than on the other models. They are already capable of working in a multi hub configuration with other hubs of the same model, and they also already make internal backups which are different than the ones on the V2 and V3 models.

4 Likes

Any news/update as to when we will see the iOS app update that supports this feature?

6 Likes
2 Likes

Got it! Thank you!

3 Likes

So I just tried to update from my V2 Hub to the Aeotec Hub. I have the required firmware version and I just received the proper version update for the ST app on my iOS device. Unfortunately, I am unable to perform the transfer of data to the Aeotec Hub due to the fact that the Aeotec Hub does not have sufficient memory. I would assume that I would run into the same issue with the ST V3 hub as it is the same hardware as the rebranded Aeotec hub. The ST Station is not an option for me because I have a considerable number of Z-Wave devices. What are my options? Is there another hub in the works that has more memory? Is there any way to expand the memory on the Aeotec or SmartThings V3 Hubs? Any other workarounds? :face_exhaling:

NOTE: I am certain that I met all the hub replacement requirements stipulated in the information pop up panel.

2 Likes

Ouch!

It’s true that the V2 had more memory than the V3. Also, than the Station. And there’s no way that I know of to increase the memory on any of those models. :thinking:

The only thing that we as customers have much control over is the number of custom edge drivers. We have downloaded to the hub. If there are any edge drivers that you are not using, you could try deleting those and see if it helps.

I’d definitely suggest contacting support and see what they say.

Let us know how it goes!

2 Likes

OUCH for sure! I am typing an email to Aeotec as we speak. I will need to contact SmartThings Support as well.

Thanks for the feedback JD.

3 Likes

I’ve deleted 12 Edge Drivers not in use and I tried again to accomplish the hub replace with the same result. I believe that all unused drivers are deleted other than a couple of diagnostic drivers. I am now going to send an email to SmartThings support…

4 Likes

wow! and this is a brand new Aeotec hub with nothing paired to it @Buds_Smart_Home? How many devices do you have paired to the V2 hub?

3 Likes

I can imagine that might have freed up flash storage rather than RAM and the latter is more likely to be at a premium.

1 Like

Yes. “No connected devices”. I did find the when I installed the hub it downloaded a few drivers, (see second attachment). I deleted those seven drivers, plus I deleted twelve unused drivers from the v2 Host Hub and I still got the memory error.

As per the attachment I have 101 devices. What caught my attention was the “1 device without a location” which caused me to question whether the Aeotec Hub was that “one device”. But it turns out that it was my old iPhone that I have now replaced with an upgraded version.

This is the tentative response that I received from ST Support:


Hi Budsmarthome,

This email is to notify you that we have created a support ticket for your request. Kindly note that our reply may be delayed due to a sudden volume increase. We will follow up with you as soon as we can. We deeply appreciate your patience.

In the course of investigating, our team may need to look at logs from your Hub and devices. To allow Customer Service to access your data, please follow these instructions:

  1. Go to SmartThings Web ([my.smartthings.com](https://my.smartthings.com/))
  2. Log in to your Samsung Account
  3. Select the Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and choose Confirm

If we are unable to investigate your request during the time frame that you selected for account access, we may need to ask you to extend it so we can resolve your issue.

If you have any questions or concerns about this, please let us know.

Warm regards,

The SmartThings Team

In other words, the standard scripted response to almost every issue reported. At least they didn’t ask you to delete and reinstall the app.

7 Likes

I logged a call last month with the UK support team and I got a responce saying they were worked at a reduced capacity due to Covid restrictions

1 Like

@Jeff_Gallagher Standard UK response there too, totally out of date and no help whatsoever…

Did they suggest a hub reset? Usually do :roll_eyes:

2 Likes

I think you are a real hero, trying this new option with 110 devices connected.

I really don’t have the guts, and may only do this after having a failing hub.
At one of my locations I have a nearly “empty” v3 hub, next to a v2 with 40 devices, but I will ony try after many over here declare being succesful.

7 Likes

I have a v2 and addes a new v3 to account. It shows up in smartthings and I’ve attempted the hub swap feature but the attempt fails with a “try later” message. I try later and get a "successful " message but the devices don’t actually move over to the new v3 hub. Any ideas?

1 Like