New device (per device!) activity feed in the new app? Am I seeing things?

While I was working on a new DTH for my Centralite thermostats, and trying to get it to work in the new app, I noticed this for each of my devices:

Also, this little graph icon is new:

Here’s what happens when you tap on that graph icon: (different device this time)


i was just in there last night and didn’t see that! runs off to play in new app


not seeing it in iOS yet. Tap your 3 dots in the upper right. What’s your Controller version?

Took a while (app still a bit slow): 1.7.29-205

Temperature looks like it’s in Celsius, but my in my Location it’s F. I see the same issue with my thermostat sliders. I can’t fix that in any DTH, so it must be a back end thing (I hope).

1 Like

I think that’s app version? Which looks like an update since 1.7.27 was what came out a couple weeks ago.

What about this screen?

All my devices look like this:

Hmmm, notice your hub’s name? Mine doesn’t say that for the device. It should say My Home Hub for me.

Seeing it on my Android phone too. The chart on mine is also Celsius despite the device being Fahrenheit. There’s also a firmware update button on the information screen of the device. I think that’s new.

Kinda strange that Android “controller version” looks like app version and iOS looks like something separate. I had always assumed that showed the device plugin version since it can update independently of the app.

I’ve been trying to get back into the new app to see what my other devices look like, but unfortunately the app has been crashing the last few hours every time I try and go into any device.

Just when I think there’s hope for the new app, it craps out on me… I literally can’t do anything in it the last few hours.

1 Like

It still doesn’t do anything, but my Aeon Minimote has a button now!

All my devices (on iOS) have the Firmware Update button but I don’t think it does anything. It even shows for my Xiaomi temperature sensors and it’s very unlikely they have updates…

No temperature graphs or event history for me either, not even on something supported like the Zen thermostat.

The firmware update button for zigbee devices has been around a while. But as you noticed, it doesn’t do anything.

@johnconstantelo are you still seeing this? Somewhat surprised it hasn’t hit iOS yet.

you can now also add devices to the phones homescreen as well for quck access, server side upgrades are nice but take the fun out of an app update… we all like an app update dont we ??

Having quick access to a device is a nice touch but backing out from the device takes the user back through the app if you hit the back button, would be better if quick access was also quick exit and the user was taken back to the phone dashboard for quick access to another device if needed

would also be nice if the shortcut icon displayed the devices state if available, this would create a user defined Smarthome dashboard with quick access, would also mitigate the need to load the full app and all its flashing loading devices


Sure am, and my favorite devices haven’t screwed up completely. Most Rooms are holding their settings, and some aren’t. I also have device names not updating when changed in Classic or the IDE.

Checking status and Disconnected devices seem fewer too. I haven’t tried enabling the SmartThings Panel again though.

Bringing up a device for the first time is very slow too, but decently quick afterwards.

@fido, how did you add devices? I only have 2 versions for Routines that the Classic app makes available.

Adding scenes to the phones desktop does not seem possible at the moment though it seems to be a no brainer for a server side upgrade in the future

Adding devices to the phone desktop is as simple as opening the devices page tapping the top right 3 dots, edit and on the edit page there should be an ‘add to home screen’ button

I jinked myself. All my Rooms just got messed up with favorite devices added on their own, and now the app crashes anytime I open a device to see if I see what @fido shows for his devices.

I just found setting a lighting automation in classic is missing the save button top right so no automations can be created, however in the new connect app the same automations are possible and can be created… weird

I have the Save option and created a smart lighting rule.