New design interface for smartthings (diy gui) all platforms

Hey every one the developer from just contacted me and said he now intergrated smartthings into his remote app. A few months ago I contacted him and gave him the idea as he had never heard of smartthings. For all those that are looking for a panel interface for tablets around the house this might be a good solution. I will be checking it out soon. I’m kinda tied up with family medical things but will soon. Please if some one else feels like it please share your experience and post screen shots of your own interface designs.


Thank you! It looks beautiful and worth looking at.

Looks nice indeed. Will give it a try tonight.

Regrettably, the labels for voiceover in the iOS app have not been coded, making this unusable from an accessibility standpoint.

Looks cool. Lack of accessibility is unfortunate, especially since Apple builds these tools into their operating system for use by every developer.


I keep getting an error in the designer. It’s pretty frustrating but I’m not very good with all of this stuff.

There are some issues, but this looks promising.
-The designer refuses to remember the oAuth keys…
-The Home Remote smart App is missing titles for all the input elements, makes it almost impossible to figure out what you are authorizing.
-There are several capabilities that are duplicates (various thermostat capabilities), and some that are of little to no value (configure, poll, actuator)

I just got it to turn on and off my kitchen lights in the Home Remote Simulator Designer…

Here’s a super quick edit of the input elements (titles added), and removal of some capability cruft.


@pstuart, you need to check this out.
In addition to ST, this app also supports an interesting list of other devices.

Thanks @Mike_Maxwell your modifications to the smart app fixes the authorization issue. In less than an hour i was able to set up smarthings, Two nest thermostats and 4 ip cameras, thanks for bringing this to our attention @guck1093.

No problem mike I thought it looked promising when I seen what it had to offer before smartthings. That’s why I contacted the developer and suggested smartthings as he had never heard of it. Now that smartthings is integrated it’s that much better and useful. I heard from a little birdie sonos intergration is coming too


Did any of you get it up and running? How does it function?

I guess, kind of.
The sim keeps returning unable to set variable xyz… So you I’m unable to use the device state to do anything in the GUI (change the text, or background colors)
So far for me all it does is send commands to ST…
Has anyone else gotten the GUI to respond to device states?

I guess i am lucky cause my gui does respond to device states but i do ocationally get the same unable to set variable message but it is solved by hitting the refresh button.

Hey Mike,
Can you add a label to your project & assign it a TextVariable of xyz (or whatever variable name you are using)?
Any variable that’s been assigned an Attribute should report back device states. After sending a command see how long it takes the label to display the updated value. Then update the variable’s ResponseTime value to reflect that amount of time. After sending a command the app will report back a failure when that time expires if the attribute value doesn’t match the value of your button’s OnState or OffState property. I’ve noticed that for my fan switches it takes about 8 seconds to respond so I set my ResponseTime to 9000 ms. This does seem like an unusually long time. I’m not sure if this is only for fan switches or all switches. My door lock states update almost instantly when the lock position changes so this slow response time doesn’t appear to be across the board for all devices.

Thanks for your input in regards to the titles for input elements. I’ve updated the app submission with those changes and I also hid the following capabilities: actuators, configurations, pollings, refreshes, & sensors. The others that you hid I decided not to because I thought there may be some people that might get some use out of them (are there any users that only want to give the app access to thermostat setpoints & not the thermostat modes?)


I changed the timeout to 9000, all the devices in my setup all report state changes in under a second, most of the time it’s half that time.
When I change state in st, the labels change in the app within a second.
Seems I only get the error when I change the state in the app.
Also, seems I should be able to change the background colors of the buttons based on state, I found and configured this, doesn’t seem to be working.
The way your app works, even if someone wanted to use set points, but not operating modes, they would just leave that out of the interface.

I might have exaggerated my switches a little bit. It actually looks like it’s closer to 5 seconds for me. But it doesn’t seem to matter where I change it. It takes about 5 seconds for the change to be reported in the Home Remote app even when the switch is turned on in the SmartThings app. I’ll have to look into that a bit more.

You did find a bug in the Button control but there is a work around. Currently in order to use “OnAppearance” and “OffAppearance” you have to provide “OnText” and “OffText”. Take a look at my button configuration in the screenshot below. I’ll make sure that gets fixed in the next release. The appearance properties probably shouldn’t be dependent on those 2 Text properties.

You make a good point regarding the other thermostat capabilities. Right now they are probably only going to lead to confusion & clutter which isn’t really necessary. I’ll remove them.

Awesome, its like QT designer for smart homes

I setup the designer and added the revised code above, enabled oauth etc. I can see the smartapp in the ST mobile app and several items are authorized. My issue is that when I try to add a variable from the designer it is not returning any devices. Any ideas???

I have the same problem, no solution?

Hey Dario, @ron_pfaff emailed me this past weekend & told me he got it going by unchecking some of the devices he previously authorized. We suspect there may be some device type or capability that the SmartApp doesn’t like. When this happens the method in that app “getCurrentValuesWithDisplayName” returns an empty string so the device drop down is empty. My recommendation would be to do what he did. Go through the process again but first only authorize types that we know work, like door locks & light switches. If you are able to get those working then you can maybe begin checking a few more. And if you can narrow down what it doesn’t like let me know. Again it could be something different but I suspect you’re experiencing the same issue.

Same problem here, tried removing it and adding it again - still nothing.

Will wait a day and try again.