New CREE bulbs not functioning as expected

Just got a new CREE bulb and installed it using my iPhone. Turns on but doesn’t turn off fully (goes to about 10% brightness). So I assumed it was faulty and got another one; same problem. All my other CREE bulbs installed a while back work fine.

Looked in the IDE. Says Type=placeholder, No Zigbee ID.

Is this to be expected with the transition to Edge? I can return the bulbs but it may not be a CREE problem but a SmartThings one. If the latter, the transition is being handled in a piss-poor manner.

Placeholder is normal for Edge Devices and WiFi Devices. Do NOT change it as you can mess things up.

It is messed up already. Something has changed and now the bulbs don’t function properly.

What driver are you using?.

Have you tried @Mariano_Colmenarejo ZigBee Light Multifunction Mc driver?

I used my iPhone and the SmartThings app to install the bulb. The driver was whatever the app selected and I have no idea how to change it.

Issue is I have several of the same bulbs and something has changed recently that renders the installation ineffective as far as functionality is concerned.

Use this link to access @Mariano_Colmenarejo drivers.

After you install the driver. Open the device tile. One detail page click on 3 dots in upper right corner, select driver, than select different driver.

I installed the Zigbee Light Multifunctional Mc driver and rebooted the hub. Still no luck. I can change the brightness but the bulb will not go below about 10% illumination even when told to switch off.

Sorry, I am out of ideas. Maybe @Mariano_Colmenarejo has some ideas.

Hi @bluebanana

It’s a little weird.
The ones that work well are the same model “Connected A-19 60W Equivalent”?
What DTH do the ones that work well use?

The bulbs I have are the A19 CREE bulb

I haven’t done anything fancy. Before I used the SmartThings app to install the bulbs and they work just fine. Now the two that I’ve tried say in the IDE “placeholder” for Type and there is a blank for the Zigbee Id. All previous bulbs say “Cree Bulb” for Type and have a Zigbee Id. Changing “placeholder” to “Cree Bulb” has no effect.

So something has changed for the worse.

Hi @bluebanana

You must forget if the IDE puts a placeholder or not and if it does, don’t touch it, the only thing you can get is that it doesn’t work and you have to uninstall it again.

If you say that you have other bulbs that work well, look at those bulbs and see what type it show in IDE and what model they are.

All the bulbs are the same make and model. The only difference is that I installed the earlier ones (8 or so) months ago and that went fine. The two I installed last week don’t work properly. Either I have two identically faulty bulbs (unlikely) or something has changed in the SmartThings installation. The older bulbs say “Cree Bulb” in the IDE Type, the new ones say “placeholder”.

@bluebanana

Did you try to uninstall the drivers edge zigbee switch and zigbee light multifuntion Mc and install the bulb?

As it seems that it is in the smartthings production Zigbee Switch stock driver and it also works badly, we can tag to @nayelyz to check what happens with this device

I uninstalled the bulb and used a fresh installation procedure using the SmartThings app on my iPhone. Still the same problem.

I have a few really old Cree Smartbulbs that are working fine after I re-added to the Hub a month or so ago. They obviously where installed using the SmartThings Edge production driver since I see driver option on the Cree device’s menu.

Looking at the production Edge Zigbee Switch fingerprints file, I only see one entry for a Cree smartbulb so I presume that my Cree smartbulbs are using it since they are A-19 60W smartlights, but can’t say for sure.

id: “CREE/Connected A-19 60W Equivalent”
deviceLabel: CREE Bulb
manufacturer: CREE
model: “Connected A-19 60W Equivalent”
deviceProfileName: on-off-level

Thanks for the tag, @Mariano_Colmenarejo.
Sorry for the delay, @bluebanana
So, currently, which driver is your device using (The one from SmartThings or Mariano’s)?
If it’s the one from ST, it makes sense it is picked by default as the device’s fingerprint is included in the production version.
In order to see what is happening we need to look at the driver’s logs. To do so, please help us by installing the CLI and running the command below:

smartthings edge:drivers:logcat --hub-address=x.x.x.x

You need to replace x.x.x.x with the actual Hub’s IP address which you can find in the IDE or your router’s configuration.
Then, execute the off command from the app to see the messages exchange between the Hub an the device.
Then, you can share those logs here, over DM or to build@smartthings.com. Thanks!

Hi, @bluebanana

We would need the logs Nayely asked for to investigate this further. If having any trouble to get them, please let us know so we can help you.

Sorry, returned the bulbs to Amazon and reused a canary bulb I had. No idea how to create logs.

Hi, @bluebanana

Thanks for letting us know.