New app doesnt support custom smartapp push notifications?

I just added SMS notification to those smartapps and they seem to be working which will be an acceptable stopgap - looks like just ios app push notifications are affected.

Is webcore one of the Smartapps you are using?

Hi @Karmit,

I just got a push notification on my Android phone and tablet, but unfortunately the only iOS device I have has already left the house so I can’t confirm if the push notification got to it or not yet.

I do have webcore installed from some previous tinkering, but no active pistons.

If you ever want to send push notifications in pistons for the new app, you will need to use “send push notifications (msg) and store in messages” in order to receive notifications :slight_smile:

1 Like

Working here on iOS 13.5.1 - from LUM


Also works on iOS14 beta :slight_smile:

1 Like

Looks like someone in ST support needs to go back to their training manuals. This is definitely untrue as verified above.

I would recommend trying the following steps

  1. Open the new ST app settings page and turn off notifications
  2. Log out of the new ST app
  3. Delete the new ST app
  4. Restart your phone
  5. Install the new ST app
  6. Log in
  7. Open the app settings page and enable notifications
  8. Verify that your mobile phone notifications for the ST app are enabled

It looks like your phones notifications are cross wired somewhere in the platform and it’s not sending them. You just need to figure out how to reset them.

Also tagging @blake.arnold who may have a suggestion

1 Like

Thanks Rboy -

Went through all of these steps and same results:

Able to receive smart things push notifications from native STHM and automation triggers, but not from smartapps.

Smart Apps (LUM/Intruder) behave as intended otherwise, able to lock/unlock/arm/disarm/alert/etc… just fine. Just not getting the notifications unless I plug in an SMS#

I replicated same behavior on another device logged into same samsung account - reinforcing the theory that it’s something in the smart things platform related to my account is not pushing to new app? Prior to deleting the old app (when both were installed), i WAS receiving smartapp notifications to the old app only. Now that old app is deleted, I can not login again to re-test that behavior.

Thanks RBoy - good suggestions. The new app supports custom smartapps, what CS was probably trying to say was that it doesn’t support all of the custom capabilities that were present in some smartapps and devices from the old app (without some work on your or the developer’s part).

I would also double check under the new app’s settings that the devices you want notifications for are selected (left menu -> settings -> notifications). A nice feature of the new app is being able to turn on/off notifications from specific devices. It’s possible that might be doing it too.

1 Like

While that does make sense to have granular device control over what is allowed to send, I have confirmed that all devices are switched to “on” for notifications (though not clear if/how smart app triggered notifications might align with individual devices for this, as only “devices” are present).

Would the IDE logs provide any useful information? I captured an intruder event (keypad panic) and LUM keypad unlock to disarm. Both should have sent app notifications, but neither did. Both did send SMS notifications as configured.

Just some updates - pointed support to this thread, and they are effectively saying they cannot support smartapps and recommend I create custom automations to be triggered by smartapps to send the push messages. While I could probably make that work, I’d lose the dynamic text coming from LUM/Alerts, etc…

I tried from webcore as well - using all permutations of send notification, send push notification, send SMS, with/without “store in messages”. Only thing I can get to come across are the SMS.

Edit: So I was able to get classic app reinstalled and logged in. Initially if I try to login to existing account, it advises “available countries could not be fetched”. If I say new to smartthings, it lets me provide credentials and logs in. When logged in, all the smartapp notifications generate as expected to classic, but still nothing to new app. No idea if that countries could not be fetched message is indicative of anything.

Working for me and no, we didn’t wash a bunch of clothes and did not dry them…The counter is reset every Saturday at midnight. :+1:t5:

Thanks - !

Frustrating…Just another sample below to validate new app notification permissions are configured to allow ( generated by automation), followed by webcore action generating notifications that only delivered to classic app. I know contact book notifications are deprecated, but looks to have defaulted to general push as expected.

While smartapps are visible in both classic and new app, do I need to do anything to “de-register” from classic and assign to new app"? Wouldn’t the expected behavior be for these messages to be sent to both apps? I did not go through the automated app migration due to negative experience reports.


Any progress on this?

I’m having the same issue, everything appears to be configured fine in my pistons ("store in messages’), I get other notifications in the new app (from native automations for example), the classic app notifications work fine, nothing through to the new one. I’ve tried so many variations, uninstalled/reinstalled the app, etc… Same issue on my wife’s phone as well.

I’m getting worried the classic app will soon stop working and I’ll lose my notifications.

Two things to check…

  1. the phone allows permissions for notifications from the app
  2. notifications are enabled in the new ST app > menu > settings > notifications

Also, look in menu > messages to see if they show there.

Yeah, got all those permissions set - other native ST notifications from the new app work.

And none of the piston notifications that are set to “store in messages” actually show in messages in the new app.

Post an image of your piston

This is just a test piston that I’m manually running with the “test” button.

The notification comes through on the old app, but not the new.

Hmmm a mystery…

Post on the webcore forum and see if anyone has any ideas.