Nest Thermostat "State" not updating?

Did any of you raise a support case for this? Im waiting feedback from support but you would hope this is a relatively easy fix…

Hi, there is a custom integration which takes advantage of the custom capabilities (and less issues):

Refer to


I’ll take a look in the morning, if you can satisfy my use case I’m more than happy to contribute.

More features, more automation variables available, compatible with all dashboards (ActionTile, Sharptools) and no throttling…

What I am trying to do is get the state of the thermostat so I can hook up an additional device to turn on/ and off as if it were hooked into the thermostat itself.

If I have read your documentation correct the minimum poll interval is 1 Minute - is that correct?

As I will have only 1 Nest device is it possible to reduce this? I assume this is because there is a Limit on API calls?


Hi, no it’s not possible to reduce the polling interval due to scheduling issue. This is a cloud-to-cloud integration, and a 1-min. interval is pretty good under SmartThings (few (local) z-wave and zigbee devices can have a 1-min polling interval btw)…

And, there is a smartapp called tstatStateTriggerHA for this use case:


I’m not we’ll versed enough in these processes. No idea how to do that.



Ontheslopes Mark Freelance
March 6

I’ll take a look in the morning, if you can satisfy my use case I’m more than happy to contribute.

Same issue here. SmartThings support didn’t seem to know about it and weren’t particularly helpful when I submitted a ticket.

That’s a bummer. I’d love to see this addressed too. We all seem to have a need to trigger an outlet/device when the furnace is on. I’d like to trigger an in-line duct fan without having to run wires all through the house. This seems like a perfect use case!

Been waiting on this bug to be fixed since the beginning of finding this thread, seems to be low on their to fix list. My workaround is to use an econlink contact sensor on the furnace, the one with the contact terminals that can be tripped with lead wires instead of the magnet. Does the job just perfect, whenever the furnace is running it changes the state of the contact sensor. The sensor is also available to the alexa environment as a routine trigger if you prefer using that to automate. This is the sensor if anyone is interested

Hope this helps some of you until the issue is resolved

1 Like

This should be resolved now, let me know if you’re experiencing anything different. Thanks for your patience while we worked with Google to sort this out.

CC @vogtrj @PhillyStafford @hindseb @Strat8409 @mglessner1977 @Ontheslopes @ethos @aaronv


:+1: Sure does, thanks to all involved

1 Like

Not working for me yet. Is there anything I need to do to get things updated? My Nest is showing “idle” no matter what it’s actually doing.

Sorry to hear that. Could you tell me more about the following?:

  1. What Nest Thermostat model you have.
  2. Where you are located geographically.
  3. If you’re running the latest App Version for iOS or Android.
  4. What “Controller version” your device is using (Open App → Click on Nest device tile → Click three dot menu in the upper right → “Information” → “Controller version”)


Here is the info you requested:

1.) Nest Thermostat Gen 3
2.) In the USA
3.) Running the latest Android version of Smart things
4.) Controller Version: 2.2.3-5

Thanks for this info. Our setups are identical. Is this still not updating? If it’s not, how disruptive would it be to delete and re-add your Nest Integration to SmartThings?

Another thing you could check is make a simple Automation off of the “Operating State” (IF: Cooling, THEN: Send SMS/Notify or other noticeable action).

If there’s any continued issues after deleting and re-adding, if you could report the issue to us via that would be helpful for us to look into this further.

I deleted the Nest integration and reinstalled it. No luck! I sent an email to support. Hopefully they can help, I haven’t had luck with support through email in the past.

Has this maybe been in Cooling (or Heating) mode the entire time since before this was fixed? (Shot in the dark). What about the Automation, did you happen to try that and that is not firing as well?

Sorry to hear you’ve had some bad luck in the past. Drop the Ticket ID here and I’ll check in on it to make sure it gets escalated. Thanks again for bringing this up.

Can anyone confirm if the Nest Thermostat reports to Smartthings when the heat is on or cooling is on? I too have been looking to trigger a fan when my furnace comes on.


Not with MyNextManager

My custom Nest integration can even detect motion & presence if you have a wired Nest model with the latest firmware (see picture above).