Nest Thermostat "State" not updating?

I have set up the newly available Nest integration, which for the most part appears to be working. I have encountered one problem though - The “state” reported by Nest in smartthings never changes from “Idle”. I would like to create an automation that turns on an auxiliary fan when the heat is running in the evening. I’ve used a similar automation with the old NST Manager app and WebCore, which required a legacy Nest account. I was excited to finally update my Nest account and bring this automation into the official app, but now my only use for the Nest automation isn’t working! Has anyone else experienced the same problem, and have you found a fix?

3 Likes

I don’t have an answer for you but I’m having the same issue. Hopefully someone can explain why the state stays idle

1 Like

I don’t have a solution, but I have the same issue. Any support to solve it would be appreciated.

I am having the same issue. The “state” of nest is one of the most useful reasons to have a Nest thermostat integrated into SmartThings. My “state” is always idle. I want my ceiling fans to circulate the warm air while the heat is on. I have high ceilings and the warm air tends to stay near the ceiling.

I cannot express how disappointed I am that the ‘state’ is not updating. These thermostats have been the biggest waste of money. They are dumb…not smart. I’ve been hosed on this trigger every since Stringify went down.

1 Like

Did any of you raise a support case for this? Im waiting feedback from support but you would hope this is a relatively easy fix…

Hi, there is a custom integration which takes advantage of the custom capabilities (and less issues):

Refer to

Regards.

I’ll take a look in the morning, if you can satisfy my use case I’m more than happy to contribute.

More features, more automation variables available, compatible with all dashboards (ActionTile, Sharptools) and no throttling…

What I am trying to do is get the state of the thermostat so I can hook up an additional device to turn on/ and off as if it were hooked into the thermostat itself.

If I have read your documentation correct the minimum poll interval is 1 Minute - is that correct?

As I will have only 1 Nest device is it possible to reduce this? I assume this is because there is a Limit on API calls?

Thanks

Hi, no it’s not possible to reduce the polling interval due to scheduling issue. This is a cloud-to-cloud integration, and a 1-min. interval is pretty good under SmartThings (few (local) z-wave and zigbee devices can have a 1-min polling interval btw)…

And, there is a smartapp called tstatStateTriggerHA for this use case:

Regards.

I’m not we’ll versed enough in these processes. No idea how to do that.

Thanks,

Matt

Ontheslopes Mark Freelance
March 6

I’ll take a look in the morning, if you can satisfy my use case I’m more than happy to contribute.

Same issue here. SmartThings support didn’t seem to know about it and weren’t particularly helpful when I submitted a ticket.

That’s a bummer. I’d love to see this addressed too. We all seem to have a need to trigger an outlet/device when the furnace is on. I’d like to trigger an in-line duct fan without having to run wires all through the house. This seems like a perfect use case!

Been waiting on this bug to be fixed since the beginning of finding this thread, seems to be low on their to fix list. My workaround is to use an econlink contact sensor on the furnace, the one with the contact terminals that can be tripped with lead wires instead of the magnet. Does the job just perfect, whenever the furnace is running it changes the state of the contact sensor. The sensor is also available to the alexa environment as a routine trigger if you prefer using that to automate. This is the sensor if anyone is interested

Hope this helps some of you until the issue is resolved

This should be resolved now, let me know if you’re experiencing anything different. Thanks for your patience while we worked with Google to sort this out.

CC @vogtrj @PhillyStafford @hindseb @Strat8409 @mglessner1977 @Ontheslopes @ethos @aaronv

3 Likes

:+1: Sure does, thanks to all involved

1 Like

Not working for me yet. Is there anything I need to do to get things updated? My Nest is showing “idle” no matter what it’s actually doing.

Sorry to hear that. Could you tell me more about the following?:

  1. What Nest Thermostat model you have.
  2. Where you are located geographically.
  3. If you’re running the latest App Version for iOS or Android.
  4. What “Controller version” your device is using (Open App → Click on Nest device tile → Click three dot menu in the upper right → “Information” → “Controller version”)