Nest Protect problems within Things and other areas in Mobile App

Just a bit of history, for a few days I have had the “unexpected error” when I tried to access a couple rooms on the mobile app. In conjunction with this I noticed my Nest Protects were no longer showing up under Things. I logged in to IDE and found the Next Protects listed there under My Devices as expected.

To root cause the “unexpected error” I assumed the missing Nest Protects and error were linked somehow and it so happens a Nest Protect was in each of the inaccessible rooms. As soon as I removed the device from the room I could then access the rooms again via mobile without any errors.

Now comes the part where I am having trouble. I could not understand how the devices were present under My Devices but not in Things. So I just decided to delete and re-add the two Protects. All seemed normal again as the devices now showed up in Things and tapping to access produces the correct information and status from the Protects. But as soon as I back out to the Things screen I can watch the list of Things collapse down deleting the Nest Protect. Completely gone yet as before still under Devices.

I decided to try a new device handler but same result. The Protect appears for one shot in the Things list and immediately disappears after the first access. However looking at Events, logs, etc… they appear to still be around and fully functioning behind the scenes. The mobile app somewhat knows the Protects are still around too as I can configure a Smoke monitor and it will show both Next Protects available to monitor but as soon as I choose one the mobile app crashes.

Any thoughts?

I experienced this same issue, Protects gone in app but still in IDE. I contacted support and got the standard reply Nest not approved product. You can use custom DTH to make them work.
Wrote back saying they didn’t answer the root question of WHY they are in my IDE but not in my app. I can’t display anything they are associated with.
Again canned response we don’t support custom DTH and I can also see them in your IDE but can offer no reason why not in app.

My fix was to remove the Nest protects DTH I was using and install the Nest Manager DTH. My protects showed up when I selected them in the new DTH / app and have been there for a while now.

I don’t know how long they were missing, I just noticed one day they were not showing up in live log when I was trying to fix something else.

1 Like

Possibly delete your smartthings app cache? I’ve had to do that before to clear weird things up too.

Glad I am not alone in seeing this. Thanks for the advice even though deleting cache and data unfortunately did not help. I also installed Smartthings on a new device that had not had Smartthings before and same issue so I think I will skip my thoughts on reinstalling ST on my tablet.

I have seen the Nest Manager and wondered whether I should give that a try. Now based upon your advice and experience that will be the next thing I do!

Just checked to make sure I had not led you down a bad trail.

Still there, still reporting in.

Just finished installing Nest Manager and it seems to be working. There is quite a bit of capability with this Nest Manager app. I am impressed and perhaps it will lead to me getting a Nest camera or something.

There is one slight thing I have not quite figured out. I have viewed the full information just like your screenshot but when I back out and come back bit later to view again I get the top half of the screen showing “CLEAR” and “Battery OK” but a spinning circle for all the other information. Maybe its a polling interval setting or maybe it is rate limited and will reset after a period of time.

I just checked and mine does the same thing. Maybe there is an answer in the Nest Manager topic. I have not read much of it. Possibly someone has already asked the same question there?

Just did quick browse of that topic. Found this:

When I open smart things app the next time, the usage details don’t come… it just keeping trying to refresh…

This is a android bug.
If you force the ST app to close then reopen it will show the data again

Good find! I have not yet started going through the Nest Manager topic. As long as things are working behind the scenes I guess I won’t worry too much about the status failing to update without a forced stop.

I just updated the Nest Manager to 4.2 a few minutes ago. Was not smooth but that was probably operator inexperience. I ran a self test on one of my Protects through the app and all necessary notifications came out. So looks like I am good to go! Thanks again for your help!!

I recommend you look into setting up the Github stuff. I fumbled through it a while back. I only know the basics, but for those programs that support it makes updating a couple click event.

I don’t remeber where or how I found the directions.

Some of my apps and DTH I have to do manually since the developer doesn’t have it on github.

It may be that I don’t have Github completely setup correctly. I did use it to update from the Nest Manager Master but I still found myself deleting the old version Smart App, handlers and devices. I am still new to this so maybe that is normal. Maybe the PC world has me too spoiled where old files are replaced or deleted. It makes sense of course but I am still learning.