Nest devices stopped updating at midnight last night (Sept 30 2018)

nest

(Tracy McKibben) #1

I have a Nest Gen2 thermostat and two Nest Protects connected to a ST V2 hub, running a variety of Webcore pistons. I noticed this morning that all three Nest devices seem to have stopped talking to ST at midnight last night. The “lastconnection” time shown for all three devices in the IDE are “Sun Sep 30 11:59:37 CDT 2018”, give or take a couple of seconds.

This smells strongly of “something” expiring at midnight, but what? I’m using a personal Nest developer account for the oAuth for my Nest devices, and everything in my developer dashboard seems to show all is well. There are no errors in ST that I can find, just nothing is updating from my Nest devices.

Help?


#2

I’m sure that’s very frustrating. :disappointed_relieved:Since there’s no direct or official integration with nest, you can’t have those devices connected to your hub. You have to be using some kind of custom code to create a cloud to cloud integration.

So the first question is exactly which code are you using? Then you should probably check in the author’s thread for that code to see if other people are having the same problem.

Or is this something that you wrote for yourself?


(sidjohn1) #3

Looks to be a localized issue…

This is the code I’m using:


(Yves Racine) #4

There is a resilient alternative for your Nest devices.


(Tracy McKibben) #5

Apologies, I forgot this wasn’t supported integration. The issue was with NST Manager 5.0, and has been resolved.