Nest Issues

Hi,
,
I am using Dianoga’s code(https://gist.github.com/Dianoga/6055918) and setup my Nest’s yesterday and it was working fine. However, today around 10am EST, my Smarthings hub stopped talking to my Nests. I try to send commands and they don’t succeed. My friend has a Pebble and a Mi Casa Verde and his broke today as well. Nest must have changed something on their end…

I opened a ticket through email on this and provided the logs showing the connection refused earlier today as well.

Try uninstalling the device and reinstalling. It’s likely a certificate issue.

Thanks. Re-adding the devices fixed it. Is this something that happens often? I only ask since I just set these up yesterday. Can’t wait till Nest opens up their APIs.

Thanks that worked for me as well.

I think the expiration is set to a date since mine seems to stop working around the same time as I see a lot of posts about it here. I’ve had to re-install mine maybe 3 or 4 times in the 7 or so months I’ve used it. I’d expect the expiry is between 30 and 60 days. Just estimating, though.

I think there’s some restrictions in the ST sandbox preventing @Dianoga 's device handler from attempting to log a user back in. I was getting some weird apache console error when it hit the e.getStatusCode(). I simply removed that check - assuming all command errors are related to expired certs (as they seem to be the most common). As soon as I removed that wrapping “if” statement, my heater instantly kicked in.

I’ve submitted a pull request here. It’s not a perfect fix, but it suits my needs better:

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.