Neo zigbee water leak sensor integration issue

Hi All,
I am trying to integrate a Neo water leak sensor (NAS-WS02B0) under Aeotec ST HUB.
HUB can recognize it, automaticly add to my home s I can pair the device, it visible in the application, but when I click on it in the app it says ‘cannot comnect, please check the device and try again’

Both device and HUB are EU version.

Do you have any idea what can be the problem and how I can solve it?


Maybe login to the IDE and see what device type is shown there. You may need to update it to something else.
Also check the Neo website to see if they have any SmartThings connection requirements.

Thanks for answering me.
Unfortunately I am not an expert in it and I didn’t find the way on the net to login to IDE. Could you share a link where I can read about or share some tricks how to do that?

There is no any technical details on NEO website about the device only commercial/marketing info. Support did not answer…

It’s getting better! I’ve managed to login, the device type was thing (nothing), managed to change to ‘water sensor capability’, it seems communication started. Tomorrow I can test it.

thanks for the help! @nameless you are a King :slight_smile:

1 Like

I recommend trying “SmartSense Moisture Sensor” as the device Type.

1 Like

I’ve set the device type as suggested. Still not perfect. :frowning:
Continuously in ‘checking status…’ in SmartThinhs App main page.
Status is Online in IDE, but Current States field is empty for all attributes. When tested device itself is alarming but no info in app.

Further advice is appreciated

Ok, that’s too bad but there’s still hope.

You may be able to use a custom DTH originally put together for the Xiaomi/Aqara leak sensor. Here’s a discussion and link to the DTH:

If that does not work, then a custom handler will need to be created.

The other option could be to use Tuya’s hub with this device and then integrate Tuya with ST (it’s called a linked/connected service if I remember right). I don’t do this, but there are others in the community that do, so I recommend doing a search to find more info on the Tuya/ST integration option if you want.

Do I need to pair the device again with ST hub after device type or DH changed?

Nope, not at all.

Thanks, I learned lot of things which is not difficult for a full beginner :slight_smile:

I’ve tried all the DH, I found for water sensor with no success. :frowning:
The best result was, with proposed Xiaomi/Aqara Water Sensor DH, to see the (probably correct) battery status. Even in Current States filed report was pretty OK
No change in ‘water:’ status when I test it with water.

and with WL4200S-WL4200 Sinope Water Leak Sensor DH,
Neither change when tetsted


I think I need to give it up. I am not expert enough to write customized DH for this shitty device.
If you have further proposal I will persist…

1 Like

More luck here with Tuya Leak Sensor Type ZN231589.

My friend @roni_cohen just manage to connect it to SmartThings using NORTEX WATER LEAK SENSOR which is in the build in list of Device Handles in IDE. No custom DTH required.
All working fine :sunglasses:



I got this water sensor, changed the DH to Nortek as suggested and it worked for say 30 min then dropped as offline. I restart the device and it’s on for 30 and drops again. Am I doing something wrong? The device is sitting no further then 6ft away from the ST hub. Any help please?

This might happen when the ZigBee network is too weak. Add some ZigBee repeaters to your network. An example for repeater could be a Zigbee smart plug or USB dongle or any other ZigBee device that is constantly connected to power. Here is a link for USB dongle

buy some dongles pair it to you hub and let it do the job


Thank you very much. I was looking into this dongle and wasn’t sure if it was compatable. Thanks again. I’ll give it a try

1 Like


I’m wondering if your friend did get these leak sensor stably connected? After much more testing, the sensor (sitting a feet away) still drops off. But it’s better in like the drop is 2 hours later. I’m really baffled as to why the drop. Any more ideas?