Need help getting MCT370 door/window sensor to work

Sercomm Corp: SZ-DWS04
Visonic: MCT-370 SMA
has anyone been able to get these window/door sensors to work
I can detect them
If i attempt the open/close i can not get them to work
If I use the Tyco door/Window sensor i get temp readings working but stay in open position (for the Visonic: MCT-370 SMA)
i don’t understand code unless someone me exactly what to do :wink:


try the SmartSense Open/Closed Sensor device type for them. see if that works.

I just tried both and no response at all… :confused:

Only other thing I can think of to try is the device handler for the visonic 340 E but doubtful it will work

I tried that already unless this is custom somehow?

in a few other posts people are suggesting this:

" for those hoping to use them, all that’s needed to get full functionality is to add an additional fingerprint to the already existing Smartsense Open/Close sensor:
fingerprint inClusters: “0000,0001,0003,0020,0402,0500,0B05”, outClusters: “0019”, manufacturer: “Sercomm Corp.”, model: “SZ-DWS04N_SF”, deviceJoinName: “Sercomm SZ-DWS04”

I have attempted this by inserting the exact, but when saving it gives me an error.
could this potentially work ?

O I am using these for temp sensors since they seem to work the best and a very consistent. I have tried to make modifcations so that it shows temp instead of open/close. Actually I would rather have it only show temp but every time I try to edit it the device stops working. Anyone able to make a few edits for me and I can use this to edit others. Thanks

apparently people have gotten them working, i just need someone to tell me how… I have scoured the internet and put hours into this still no GO… most sensors pair fine with ALMOND PLUS but other things don’t work on the ALMOD (this is how I know the sensors aren’t fully)

if anyone knows how to get any of these sensors working please speak up :slight_smile:

Are you just using them for temp or temp and contact. Because if you are using them for just temp I have used a copy of @ArstenA 's Xiaomi Aqara Temperature Humidity Sensor and applied it to this one and so far so good. Getting checkins a lot more often. You have to remember if the temp does not change during the checkin it will not report however it will give you the new checkin time. As long as @arstena is cool with it I can post it here. Still making a few mods

Checks in every 5 min

I just got the MCT-370 door sensor working, after some initial struggles. Mind you, I’m replying over a year after the original post, and I’m using the V3 Smartthings hub, so I’m not sure if the circumstances are different now. Nevertheless, here are my sequence of steps from start to finish, in case anyone in the same boat stumbles upon this thread:

(1) Add a device in the Smartthings mobile app (iOS in my case), and select the “ZigBee Door/Window Sensor” by Ecolink as a starting point.

(2) Go through the wizard, and when it gets to the step to “Remove the battery tab from the sensor,” remove the battery from the MCT-370, then press and hold down the black spike/button while putting the battery back in. Keep it held until the green LED starts glowing.

(3) After a few seconds, it should be paired as a device called “Thing.”

(4) Log into Smartthings via the web, locate and edit the device, and set the type to “Tyco Door/Window Sensor.” While you’re at it, rename the device to something more meaningful than “Thing.”

(5) Reload the mobile app and it should be fully functional, and showing open/close status accordingly.

It’s been working great since; I created an automation to lock my front door whenever the sensor detects closed, and that has been working nicely.

Hope this helps!

Thanks @JasperTey.

It gets detected as a Thing, and I can change it to Tyco Door/Window sensor, but the device does not display the status of the contact sensor (or the temp). I have tried also adding the fingerprint (from another thread) for the Sercomm SZ-DWS04 but the editor spits out an error when I attempt to add it. It is not clear to me what the error means as I am not a programmer.

This is the fingerprint they say to add:

fingerprint inClusters: “0000,0001,0003,0020,0402,0500,0B05”, outClusters: “0019”, manufacturer: “Sercomm Corp.”, model: “SZ-DWS04N_SF”, deviceJoinName: “Sercomm SZ-DWS04”

This is the error:
Org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script_dth_metadata_643033a3_7a6a_4f3b_9f37_b25073df7979: 30: expecting ‘}’, found ‘,’ @ line 30, column 113. manufacturer: “Sercomm Corp.”, model: “ ^ 1 error

It seemed to me that it failed on “,” between Sercomm Corp and model but I cannot figure out why.

Don’t know if anyone knows this stuff and is willing to share?

Try changing the Device Handler to the SmartSense Open/Closed Sensor

1 Like

That appears to have worked. Thank you very much!

I had to delete the sensor and re-add it, but it did work after that.

I was able to get an MCT-370 to work yesterday on v2 hub. I will recreate the process with an additional sensor and then write down the steps for those who need it. Will get back shortly.

1 Like

Thank you show much!! this actually worked.
I was about to throw out all my old Roger’s Alarm sensors and buy new ones.

I’m completely new to smartthings (just bought my hub today) and I’m transitioning off Rogers.
What do you mean by logging into smartthings via the web? I can’t find a way to connect to my hub through any way but the app.
Sorry if I’m getting terminology wrong here. I’ve been setting my stuff up for 3hrs so far with interruptions.

Hope I can get an answer. I’m replying to a 10mth old post…

Hey Douglas, there is a web portal that allows you to configure and do more advanced things with your devices that you can’t do on your phone app. If you search “smartthings online” in google you’ll get the result, or here’s a direct link:

Got my door sensors going now.
Thanks @JasperTey!!

Continuing the discussion from Need help getting MCT370 door/window sensor to work:

I have tried it, I can connect but no status is displayed. Only shows connected.

Have you tried going to the web portal and checking what type the sensor is showing up under? It might be under the default, which is 2015 Samsung smart tv. Change the type to tyco door/ window sensor and it should work properly.