Nearly half of my Things are unavailable (December 2018)

I had a similar issue today where I power cycled my Hub and quite a few of my zigbee devices dropped off. Mainly Iris motion sensors and iris leak sensors. They had been working perfectly for a long time. Something about power cycling the hub kicked them off and they just didn’t want to re-connect. I have gotten a few of them to kick back on by reinserting the batteries, others are still off.

None, AFAIK.

I have (all working, except where noted) Philips Hue bulbs (2 set as Kudled Color Bulb and 3 as ZLL dimmer bulb, all non-responding), Ikea TRÅDFRI bulbs (8 ok, 3 offline & non-responding), dimmers and switch, Samsung multi, arrival & motion sensors, Samsung SmartPower socket, Xiaomi motion and door sensor.

I have just noticed that the Philips Hue bulbs that were set up with Kudled type are reporting DEVICE source events (switch off/on) when I switch at the mains (they have been left with mains on at the switch permanently up until today), but they don’t respond to on/off commands from the app.

OK, you actually have quite a few zigbee repeaters in that mix as all of your bulbs which are directly connected to the smartthings hub will act as repeaters (although they can be very bad repeaters and lose messages) and the pocket socket is also a repeater. ( sengled brand bulbs don’t act as repeaters, but you didn’t list any of those.)

Battery powered devices generally do not act as repeaters.

If you want more background on all of this, read post 11 in the following thread, then go up to the top of it and read the whole thread.

And here is more details about bulbs if you are interested:


Anyway… Whenever you remove the smartthings hub from your network, which can include a power outage, intentionally removing it, or a hub firmware update, it is possible that the way your network had arranged itself, that is which end devices use which repeaters, Will get reshuffled. Sometimes this is because devices come back online in a different sequence then you had previously added them. (For example, if a pocket socket is getting a firmware update, it may stay off-line long enough that its previous “children,” The devices which were using it as a repeater, may start looking for a new repeater/parent.)

In most zigbee installations this is not a big deal because the devices are all pre-selected as being compatible.

With SmartThings, individual customers can add all kinds of different devices, which is nice, but it also means they can start selecting devices like the xioami ones which aren’t really engineered to work with gateways other than their own. Or they can start using devices like Hue bulbs in ways other than the manufacturer intended (like attaching them directly to a smartthings hub rather than going through the hue bridge).

All of which means your mesh may not work as well as it did before the hub went unavailable. Messages may get lost, devices may even be “orphaned” without an available parent, Some repeaters may be overburdened.

I’m not feeling very well today, so I’m sorry, I’m not up to walking you through the individual steps for checking whether this is what’s affecting you. Hopefully some other community members will jump in and help. Also, unfortunately, smartthings doesn’t give us any network mapping utilities to help with the process, so it can be quite a bit of trial and error.

But as a former field tech, if I were looking at your situation and given what you’ve already tried, I would start by testing the strength of the mesh. That’s particularly true because some of your devices are working and some are not, which would lead me to start looking for orphans or overburdened repeaters.

I’m sorry I can’t give you an easy answer, but the mesh that you had was pretty fragile, and it wouldn’t surprise me if something snapped this time around.

1 Like

And a little bit more on zigbee mesh and specifically on some of the Xioami issues:

It’s also possible you got caught in whatever this is:

@johnconstantelo May have some thoughts.

Ok I misunderstood your question re: Zigbee repeaters.

I am beginning to think that my mesh got disturbed by the firmware update, principally hitting the Philips Hue bulbs.

My hub is in the lounge, all 7 Ikea bulbs in the lounge have continued undisturbed. An Ikea bulb in line of sight 5m away in a dining area also continued fine. But 2 Philips bulbs, one outside bordering a window above the hub, the other in the hall line of sight 3m from 6 of the Ikea bulbs, have both gone offline. These 2 bulbs really couldn’t have better mesh connections to the hub.

Another Philips bulb is outside the back of the house, 2m line of sight to the Ikea bulb in the dining area. A fourth is outside the garage on the same (front) side of the house as the one bordering the window above the hub. A fifth is on the first floor landing above the hall. All these are offline.

I suspect these have gone offline because the first closest 2 Hue bulbs went offline. The remaining bulbs upstairs are Ikea and are offline, probably dependent on their connection to the landing light and the garage light.

Now I did replace (a week ago) a dumb bedside bulb which attached to the Smartsocket with an Ikea bulb, thereby taking away one of the known (reliable) Samsung repeaters upstairs. I’ve now plugged the socket back in to the mains in that room and it is responding ok. I’m going to try rebooting the hub.

But none of this explains what killed the Philips bulbs in close proximity to the hub. Nor the fact that the one with the Kudled driver is reporting switch on/off of the mains, but does not respond to the app.

1 Like

Ever since this update ALL my devices are “Unavailable.” My lights, door sensors, and plugs. EVERYTHING. I have rebooted multiple times. I have refreshed the app, taken out light bulbs… nothing works. This is absolutely ridiculous.

It also depends what other zigbee devices might be around. Each bulb can probably only have 3 to 5 children. Since things may have gotten added back in a different sequence after the firmware update than they did when you first put them on the network, It’s possible that they ended up with different parents because their previous parent had all the child slots filled before it got their request. Or even that it was just busy adding a different child at that moment. (As you can imagine, the network gets more complicated when you have 20 or 30 devices all trying to join at once and when you are just adding one new one to an established network.)

So it’s not just their physical location: it’s what parent were they able to find at the time that they were trying to re-join the hub? There are a lot of different factors that go into the algorithm that which parent gets chosen, but if the parent is busy adding another child, they might go onto a second best or even third best choice. So things can get pretty scrambled.

One thing you could try, although I know it’s tedious, is to turn off the current to everything except the hub, including taking the batteries out of battery operated devices, and then just Power on one of those two Hue bulbs and see what happens. If it recovers OK, then power on just the second of those two bulbs. ( i’m not saying turn the other devices off with the app: I’m saying actually cut the power to them. Not remove them from the network, just kill the power.)

I have a could of devices that show disconnected, they were working yesterday. One is a GE Zwave light switch, and the other is a peanut plug. They show as disconnected and uncontrollable in the new app. If I go to the classic app I can control both of them. The new app still shows them as disconnected, but if I go under activity it shows the status change. I had this happen last week also and it fixed itself after a day.

Oh I do, and after spending the last hour getting stuff back online that ST keeps crapping on, I’ll provide my 2 cents about this $hitshow and dumpster fire I’ve been in since they released firmware 24.11, which continues in 24.20.

I’m so ready for a change. I’m sick and tired of this crap.


Tedious isn’t the word!

I think I’ll wait until the problem caused by the hub FW update is fixed.

1 Like

Oh this has something to do with the Firmware update. I lost a few zigbee devices my father lost a couple zigbee devices. Don’t remove them you can’t get them to discover again. I have brand new spare zigbee devices and the hubs can’t discover them none of them even laid them right next to hub. I’ve tried at my house and my fathers. Seems they broke something with zigbee. What’s strange is some zigbee are still connected and working. Hope they fix this soon. These went off line 2 days ago just showed unavailable.

Yup, same here. I have an Iris sensor that’s been fine for years that dropped and it will absolutely not work right now. I had to rejoin it several times last night, and it’s dead this morning, or I should say it’s not reported anything even though ST says it’s online. It’s in a location with wild temperature variations, and prior to the last 2 firmware updates I’d see a change every hour or so. With 24.11 and .20, nothing. It’s less than 3 feet from a zigbee repeater too. I’ll try again when I get home from work today.


Hope they realize there is a problem and they fix it quick. Wonder if there is anywhere to report a bug?

If they do, which I hope, we’ll never hear about it.

Just an email to support, and sometimes in the Community (would not rely on that at all). ST has been awful quite lately on discussions about the last 2 firmware release.

1 Like

Rick, to contact SmartThing Support go to:
Near the bottom of the page you will find a link to their email as well as Live Chat.
They do not believe that the problem is a result of the firmware update!!!
Everyone with this problem should contact them and then maybe something will be done about it.


Your link is to UK support, btw. (“En-gb” = English, Great Britain).

US customers should use

The contact options are a little different (phone instead of chat).

I have my 5 Philips bulbs back online following advice from Zach at ST to reset the bulbs (I used a Philips 4 button remote switch held close to the bulbs), then re-join them without deleting them in the app (Add a device then turn the bulb on). I did all this with the bulbs in situ so it wasn’t too bad. Still have the 3 Ikea bulbs to revive, but then everything should be back to normal.