My thermostat keeps gets unwanted setHeatingSetpoint commands

I have a HeatIt thermostat that gets unwanted set points commands, which means that the temperature set point keeps changing. The thing is, that I used to have a smart app connected to the thermostat that lowered the temperature during the night but now I don’t want to do this anymore. Unfortunately, there is no smartapp connected to the device anymore (I guess it disappeared in one of the updates) but the device keeps on getting the temperature set points that I previously setup. Any suggestions on how I can resolve this?

Just because you may not see it doesn’t mean it’s still not running. First, make sure that you’re looking in the right Location, next look through everything you can in the IDE for that SmartApp.

When you mean disappeared, do you mean from the IDE?

It looks like the SmartApp “Cool Down” sent the command, so it’s there somewhere!


Regardless, if you can’t find it anywhere I’d reach out to support.

It’s easy to find the app. Click on the timestamp on the left column. That will give you all the details about the event including the SmartApp ID of the app which sent the command. Can use that ID to track down the app using the SmartApps tab and replacing the URL ID with that ID. There is also a installed SmartApp id available which is harder to track down but you can do it using the ST Classic app. I wish the new app had the ability to track down SmartApps connected to devices like the Classic one does. You can also track down apps by clicking on your device in the IDE under my devices which shows all connected SmartApps.

@Jejsson, all good info from RBoy too. When you look in the IDE at your device, down at the bottom will be “In Use By”, like this:


Thanks for the quick responses guys. I think I was able to solve it now, with the information given, but I will have to wait until tomorrow until I know for sure.

1 Like

Yes, problem solved. Thank you.