My custom ct100 device type

communitydevices

(Larry) #1

Here you will find my custom ct100 device type… changes include the following:

  1. add some icons and colors heat color, cool color,
  2. add operating mode tile ie idle heating etc.
  3. add color for humidity as well
  4. get rid of sliders that worked like crap and added up down arrows for both heating and cooling,
    and color based on temp for both.
  5. add color for battery status.

new version 4 … something they did in last go around of changes only allow temp to update 1 degree every 30 secs… changes delay timing to allow a change per 1/2 sec.

new version 5.
added last update tile. so you can verify it is still communicating … details last time current temp was update from thermostat. note: there is a new input preference tzoffset wich defaults to -5 and you must set to get accurate times.


Go Control battery thermostat partially works
(Edward Pope) #2

Thank you so much. I know that many of us will enjoy the new features,


(Michael) #3

@Lgkahn Thanks for sharing! Looks good, giving this a try.


(Aaron) #4

Thanks works great! Tried in both of my thermostats.


(Sully) #5

The one thing I might suggest is changing the Heat and Cool Labels to:

label:’${currentValue}°\nHeat’

That way it puts the value on a separate line from the word. It makes it a little more readable to me, but it’s not a big deal, just a suggestion.


#6

Looks great, much easier to use than the original one with the sliders.


(Larry) #7

v 2 posted with some line feeds/carriage returns as recommended on indicators to move values below labels.


#8

thanks for this… those sliders sucked :frowning:


(Michael) #9

Good call on the carriage returns for v2, looks good.


(Paul) #10

Very Cool!! I understand how to create this in IDE but I’m not sure how to replace my current CT100 device with this one. Do I need to remove the old one first? I tried replace but that doesn’t do much.

Thanks


#11

https://graph.api.smartthings.com/device/list

click on your device, choose EDIT

change the “Type” to “My CT100 Thermostat”

it should now show up in the app


(Paul) #12

BEAUTIFUL! You Rock! Looks Great!

Thanks Sir!


(Aaron) #13

Neither of my thermostats use cooling is there a chance someone could post the code without the cooling icons? Happy to send some beer money.

Thanks


#14

Much Appreciated, this looks great and for once…functional!


(Larry) #15

Unfortunately there is no way to put options on the use of tiles. I’d love to.have it configurable… but until.smartthings allows u to add optional.tiles I’d have to.maintain 3 versions. When I get a chance I will code a heat only version.


(Cliff Harris) #16

I love the new I terface, its way better than the stock one. Manually it works great, but none of my phrases or smartapps seem to be able to trigger changes on the thermostat. The log shows commands were sent, but no changes are made. Any ideas?


(Ernie) #17

I am experiencing the same issues as @revrenhex.


(Larry) #18

does it work with the old driver… because I didn’t change anything like that unless the smartapps are trying to use slider specific stuff to set it… then there is nothing I can do about that.

what smartapps are you using…i need one where the source is available so I can see what it is trying to do… remember my driver is based off the stock driver… also I know for a fact that the smartapps are reading the temp correctly as I have many and that is working fine. you may need to do an oauth on your device in order to set it correctly


(Ernie) #19

I am just using the routines. It worked with stock app. The commands are sent but no changes are made in the app or device.


#20

Well I have just been following this thread. Haven’t changed to this device type yet, still using stock. And noticed that as of this morning my ct100 is not changing based on routines. Looks like command sent but thermostat doesn’t actually change. So perhaps the issue is with smarthings in general and not this specific device type.