Multipurpose Sensor Fault?

Hello, I bought my starter kit at christmas and everything has been working well until today.

The multipurpose sensor had been working for door opening, temp and recently i added vibration for knocks on the door.

Last night it told me the front door was open when it wasn’t and stopped responding to the door opening - so i removed it and re-added it to the hub where it worked again briefly but now it just shows open and occassionally closed - it flashes between the two quickly on the app.

Is it faulty and if so how do i replace it as it was part of the kit? or is there something else i should do?

I’ve also recently added two of the Xiaomi Door/Window Sensors to the hub using the device handlers published on here, will that be having an affect? i’m assuming not but thats the only change i’ve made recently.

Also got two Hive Bulbs directly connected since Christmas which work well.

this is its current status - the front door has been shut for 20 minutes:

temperature: 17 C
battery: 78
contact: open
threeAxis: -43,-952,-241
acceleration: active
checkInterval: 720
status: open



Raise a ticket:

The folks over there are very good. They’ll help you troubleshoot and should be able to sort you a replacement if required.

Good luck

thanks. I’ve sent them an email.

The other sensors cannot affect the sensor but the bulbs could as they can act as repeaters. I’ve no experience of the hive bulbs but personal experience of osrams directly connected to smarttthings were not great.
Try disconnecting both bulbs from mains, then take the sensor and perform a full reset close to the hub. See if this resolves the problem.

I have been experiencing the same problem for a while now. Initially support were very good at responding however they have not been able to resolve the issue and I am certain the sensor is faulty. Since I have exhausted all troubleshooting possibilities they have taken to ignoring my emails. I opened up a second ticket and after re-explaining and then asking for a replacement before my warranty expires, their replies have dropped off a second time. They claim they had no response from me, but I have now sent them 4 messages that they have ignored.

The build quality of the sensors are not great. I have had a number of sensors DOA before I manged to get my house up and running properly.

At present support are claiming that there is a ‘software issue’ causing these problems however as I have pointed out it is only on one sensor. I suspect part of the problem is that they are struggling with their supply chain and can’t actually physically fulfil RMA requests. It is a real shame as the smoke and mirrors had paused me recommending to friends, family and colleagues.

Not sure if it will help however these are the troubleshooting steps I have tried albeit to no resolve (I am 100% convinced the sensor is faulty). It may be worth a try for yourself though.

  1. Deleted, reset and re-added the device to my Hub

  2. Deleted, replaced the battery, reset and then re-added the device to my Hub

  3. Re-positioned the sensor and the magnet on the same door

  4. Switched the sensors location from my back door to my front door. The front door sensor continues to work in the new position of the back door however the rear sensor continues to generate false alerts and data in it’s new position.

On The Web IDE interface:

  1. Disabled ZigBee Unsecure Rejoin

  2. Restarted the Smartthings Hub

  3. Enabled ZigBee Unsecure Rejoin

  4. Restarted the Smartthings Hub

Let us know how you get on. Good luck!