Motion Activated lights during the night—how do I set this up?


(Jordan Emery) #1

I have a z wave motion dimmer in the bedroom. In the actual light switch I am not sure of the settings. I want the light to be motion activated and shut off after 15 minutes, however when the mode is switched to night, I dont want the switch to turn on with motion. In the morning, I want the switch to turn on the scene Bedroom (Morning) but I dont want it to actually turn on the light, just if motion is detected. During the day, I want it to use the day scene when motion is activated, and the same with the evening. I am obviously very new to smartthings and home automation. There is definitely a lot to learn and I find it very interesting. Please let me know what additional details are needed…

I have created a few different lighting scenes:
Bedroom (Morning) Brightness 1%
Bedroom (Day) Brightness 100%
Bedroom (Evening) (Brightness 20%
Bedroom (Night) Brightness 0%

I have used Smart Lighting to create some programs:
Bedroom Light (Morning)
Bedroom Light (Day)
Bedroom Light (Evening)
Bedroom Light (Night)


(Mavrrick) #2

My setup is simply two automations. One that turns lights on during the day at 100%. The second is at 20% for at night. It changes between them based on sunset and sunrise. I also have them both set to not activate in certain modes for the hub. When I run the good night routine the hub goes into sleep mode so neither automation kicks in.


(Jimmy) #3

Have you setup routines to change the mode of SmartThings?


(Mavrrick) #4

All I use the the mode for is to determine if the routines activate automatically. I the goodnight routine sets the mode to sleep and then I have a wake up routine e that sets it to home.


(Jimmy) #5

That’s good. Now Set your smart lighting rules to only run in certain modes.


(Jordan Emery) #6

I do have it so it changes the “mode” to Night in the “Goodnight” routine.


(Jordan Emery) #7

Thank you all for the advice. I went in and made sure that the routines were set to be controlled by the mode. Now when I turn on the “Goodnight” routine, the bedroom light does not come on!!! :slight_smile: However, when I perform the “goodmorning” routine via alexa, I get an error saying "Your goodnight routine was not completed because it contains locking or security devices unsupported by alexa. I am assuming it is because of the smart home monitor… Set smart home monitor to Disarmed when we wake up. When i run the goodmorning routine from ST, it works, I only get the error through alexa…


(Alex) #8

Either remove the security device or trick Alexa using a virtual device in between. I wish Amazon lawyers would stop defining what Alexa can and cannot do. However there is hope… I can now unlock a door using Alexa by providing a PIN without any trickery.


(Mavrrick) #9

Be very careful about automating anything to do with disarming SHM or an alarm. It really isn’t an alexa thing, but pretty standard across the security industry to not automate that option. Remember disarm is also normally used for clearing an alarm.


(Jordan Emery) #10

Thank you for that piece of information. There is so much to learn! You have been a tremendous help already!!!