Monoprice 4 in 1 - Trouble Including

I know there are a number of 4 in 1 topics out there. Many are either old or do not address my issue directly.

As part of my SmartThings system rebuild needed following their flub last week I am down to a single device I cannot get repaired. I have a Monoprice 4 in 1 that was working fine before the implosion last week. When I try to include this again it is pairing as either a “Z-Wave Sensor, Device or Switch” depending on which direction my dog is laying. What is actually happening is the fingerprint is getting set to zeroes. I do not have a custom DTH loaded for this. I have tried excluding, resetting and including about 15 times now. Same result each time. Fresh, non-rechargeable batteries too.

Any clues? Did my 4 in 1 get upset with Samsung and give up the ghost?

I have the Z-wave sensor PH Edge driver already installed wihich it was using before last week.

Replaced it a with a new Zooz 4-in-1 and it paired-up no issues at all.

Guessing the Monoprice is toast.

Despite buying a Zooz and that working I’ve been trying to breathe life into the Monoprice still.

No matter what I do it always includes with a zero fingerprint. I’ve even had it add using a generic DTH a few times.

I swear this thing was switched over to Phil’s edge driver and working fine before it was deleted by SmartThings weeks ago.

Just posting again should anyone have any words of wisdom.