Monoprice 4-in-1 Multi Sensor (15902)


(Michael) #1

I have been poking around the forums reading up on past experiences with these sensors and not finding the information I am looking for. I picked up a couple of these sensors last month to cover more rooms in my house and was really focusing on the light sensors for some specific uses.

When initially paired up, they were acting only as motion sensors with the default handlers. I then went and grabbed the code from rboy and updated the configuration. Great! Well…kind of. I at least see temp and humidity from both sensors…but only see light from one and motion from the other. What gives? Did I really get two bad sensors with different failures?

Sensor 1

  • light is NOT reporting
  • temperature is reporting
  • humidity is reporting
  • motion is reporting

Sensor 2

  • light is reporting
  • temperature is reporting
  • humidity is reporting
  • motion is NOT reporting

I have replaced the batteries, excluded and then included them with no change in behavior.

Any ideas? Or just RMA both to Monoprice for replacements?


(John P. Hoke) #2

If my memory serves they are the same as the Zooz 4in1 sensor – try that DTH for giggles … if they continue to be fubar then yeah you have 2 bum units :frowning:


(Michael) #3

Switching to that DTH is on my todo list to at least test…however in theory the RBOY DTH is the “official” proper one to use…maybe.


#4

I bought two of these units and I also use Rboy’s DTH and so far I haven’t noticed any problems although they do seem to be going through the batteries pretty fast. It’s only been at most a couple of months and I’m down to 30-40% already.


(Kevin) #5

That was true with Zooz’s first release, but Zooz has released a couple of firmware updates that have fixed some stability issues and added additional configuration options.


(Michael) #6

Switching over to one of the Zooz DTH did not resolve the issues with both of my sensors…however I find them to be waaaaaaaaaaaaay more useful and detailed than the ones from RBoy. Looks like I need to RMA both to Monoprice for replacements.


(John P. Hoke) #7

Do you have a URL for the FW? And what is the current version?


(Kevin) #8

I don’t believe you can perform a manual firmware update, but if you purchased the Zooz device from The Smartest House, contact their support and they might be able to assist you.


#9

Recent changes to the ZSE40 include a hardware update. The PIC (the hardware part of the motion sensor) was also updated to optimize motion detection. This unfortunately can’t be upgraded remotely since it’s a hardware change. If you’re having any issues with your Zooz sensor, please get in touch with our support.


(Michael) #10

I went through what is claimed to be the factory reset procedure on both sensors and then included them back into the hub using the RBoy Monoprice DTH and one device is working correctly (I think) and one still has a dead light sensor. I have not had any time to do any detailed testing yet, but the good sensor at least is providing data for all four sensors now. This week I will be swapping it with one of my known good IRIS motion sensors to see how well it behaves.

The bad device is finally boxed up ready to go back to MP for a replacement.


(Eric) #11

@michael2 , do you feel the Rboy (RBoy?) DTH is now better for the 15902, rather than the Zooz DTH? I just got a couple of these devices.

I’ve not used any RBoy apps or DTH before, so wondering if it’s worth a subscription.


(Michael) #12

I have no real issue with the RBoy stuff. When troubleshooting, the Zooz DTH gave more info on status. Now that I finally stabilized, I am back to using the RBoy DTH. I look at it this way… RBoy has several DTH that I can use as well as an app or two of interest…it was worth the investment to me.