Mode Changes Not Working-9/8/2016


(Marc) #1

Last 2 days none of my mode changes are working. I use a combination of the supported Home Mode Director app from @slagle, as well as CoRE rules for other modes and nothing is working. I have rebooted the hub, reinitialized the smartapps from the mobile device and clicked “update” in the IDE Smartapps section. Nothing has worked so far.

I noticed in @slagle’s smart app, I see in Job History:

Job History
Handler Scheduled Time Actual Time Delay (msec) Execution (msec)
setAway 2016-09-08 11:00:09 AM EDT 2016-09-08 11:00:20.776 AM EDT 11776 917
setAway 2016-09-08 10:55:52 AM EDT 2016-09-08 10:55:52.059 AM EDT 59 213
setSunrise 2016-09-08 6:40:09 AM EDT 2016-09-08 6:40:09.077 AM EDT 77 10730
setSunrise 2016-09-08 6:34:47 AM EDT 2016-09-08 6:34:47.048 AM EDT 48 547

I also opened a case with support just now, but community always comes through faster.

Do we have a more platform wide issue here?


#2

I have some Pistons that change Modes for me. My Night and Home ones did not work yesterday or today. But my Evening and Away did.

I wasn’t sure that it was Core specific though, since I had my Good Morning Routine (lights on and plug on only, no mode change) fail yesterday and today as well. But all my other routines seem to be working.

I figured I would jump on help chat when they get in.


(Marc) #3

Ok, thanks. This leads me to believe this is more platform/server wide if other people are having issues the past 2 days.


#4

I’m seeing some things in threads about it abd some responses from Help that its specfic apps they are using. So people really need to keep opening tickets on this so they realize its more widespread than specific user apps.


#5

Yeah, taking the easy way out again instead of responsibility for a barely passable cloud platform. Better shut up now or they’ll block me…

J


(Marc) #6

This is why I mentioned I am using a “supported” app that is not working also in my support ticket. I don’t want to hear that it’s CoRE’s problem…


#7

Well I have an app (I wrote) months and months ago. It stopped working on the line (unchanged and working for months) that changes phase:
location.helloHome.execute(settings.switchedOn)

The error, which started last night, produced is:
error org.hibernate.LazyInitializationException: could not initialize proxy


(Marc) #8

@slagle - Can you help here?


#9

Just did a test with the ST App “Routine Director” and it appears to bomb as well. Produces the same error as my app does

12:05:51 PM: error org.hibernate.LazyInitializationException: could not initialize proxy - no Session @ line 203
12:05:51 PM: debug Performing "Goodbye Day" for you as requested.

#10

We’re taking a look. Thanks for reporting it.


#11

Yeah, I noticed that Routine Director was hosed this morning and yesterday evening too :frowning: I run it at a remote location, but that location was in Away mode already. At my current location … well, that was chaos in the making — didn’t switch to Home mode (from Away mode and SHM armed), so sirens blaring, lights flashing, etc., when I came home yesterday.


(Marc) #12

@Tyler I saw the message about ST apps now running, was that referring to this issue and has it been fixed?


#13

No, I don’t believe we’ve deployed the fix yet. Should be pretty soon.


(Marc) #14

Ok thanks, I guess that was another issue.


(Marc) #15

Seems to be fixed now.


(Dan) #16

Mines not fixed yet…
Why don’t we get notified of updates?
Like a quick email that says "Hey, we pushed some updates through"
Then at least I’ll be on the lookout for failed rules


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #17

Subscribe to THIS via RSShttp://devblog.smartthings.com/comments/feed/


(Jason "The Enabler" as deemed so by @Smart) #18

There seems to be a lot of reports of mode changes not working and ST reports app execution is degraded.

What I’ve noticed in all of the forum posts that I’ve read is that the mode change failures are when there is a third party app changing the modes.

I have personally seen pistons not running as well as askAlexa macros not performing correctly.

All of my actual mode changes are being done with ST routines. They have been that way four months without a problem.

It would seem that your mode change failures are actually a result of the smart app failures.


(Joe) #19

My modes didn’t work in the evening earlier this week. I use all smartThings supported routines because I don’t want to have to argue with support.


#20

So I assume everyone is still having problems with Modes and Core? I havent heard back and I have an open ticket, so I assume they have not yet found the problem, or maybe just not found the solution?