Minoston Smart On/Off Switch MS12Z

Has anyone installed the Minoston Smart On/Off Switch (MS12Z). These are pretty new as they just received ZWave certification on 8/26/19. Anyway, I can’t get this one to play nice with SmartThings - 3 presses of the toggle are supposed to initiate pairing, but my hub is not seeing it. The switch works fine manually. The seal on the box was broken - did I get a return from Amazon? Any help would be appreciated.

Try running a general device (Z-wave) exclusion And pressing 3 times on the toggle. Then try pairing it.

1 Like

I did the general exclusion with the 3 presses of the toggle, but the switch still won’ t join. I also did a factory reset on the switch to no avail. I’ve also tried varying the speed of the 3 presses of the toggle. At this point, I’m ready to stop, back up and re-think this thing.

I bought two of these switches, so I tried the other one - no joy. Rebooted everything on the network including the hub to no available. A couple curious things do happen. On the general exclusion, the process never completes as the hub never seems to see the three toggle presses, so I have to canx it after several minutes. When I try to add the switch, I select Add a Thing in ST and then toggle the switch 3 times. I repeat this 3x toggle and several times I have gotten a red warning box in ST stating that there are network problems and I need to check the network connection - I’ve never seen that before. I have tried adding the switch from both the classic and new app to no avail. The switch is located about 40’ from the hub and about 10’ from a Ikea Tradfri plug which should act as a repeater. I am using a v2 hub rev E and am on FW 000.027.00009. I have somewhere around 50+ sensors and switches and which all seem to work pretty well. Anyone have any suggestions to get these things connected?

IKEA Tradfri plugs are zigbee, not zwave, so they can’t help your zwave switch. (Zigbee repeats only for zigbee, Z wave repeats only for zwave)

JDRoberts - Thanks - I was thinking the IKEA plug was Zwave, but I was wrong. So maybe it is a distance issue as I am about 40’ from the hub with several walls in between and no other devices which could act as a repeater. I guess I will rig one of these switches closer to the hub and see it it will connect. If so, I have a location where I could install it that would cut my distance in half.

Thanks again.

1 Like

When I try to add this switch to SmartThings, it wants me to choose a company. Minoston is not a choice. What company are you using?

The instructions everywhere say “Press switch 3 times. But it’s an Off/On toggle! Press Off three times or On three times?

My first impression is “Cheap Chinese Junk”.

My problem was distance from hub with no repeaters. I ended up adding a mains powered repeater and the the Minoston On/Off switched paired immediately and has worked fine ever since. I believe your are supposed to toggle from the center position to off 3x rapidly.

Good Luck.

Confirmed working via ST Classic App.

I was able to add my MS12ZS switch, but none of the auto on/off work properly. I deleted the routines and just set to on/off at set times and thing just keep turning back on. I turn it off at the switch or app and moments later just turns on. I’ve tried to delete the device and just get error message that device can’t be deleted because it is operating normally. “huh?” Well, my summation is that this Minoston device is crap and I will be sending it back. Will see how my GE switches work if I ever get around to installing them. :slight_smile:

Pinging this thread since I was unable to find anything elsewhere. Does anyone know if there an edge driver for the Minoston MS12Z on/off Toggle switch? It appears to work with the standard zwave driver but does not allow for configuring the led in the toggle. The original device handler allowed to configure if the led was on when on -or- on when off.

This might help

I’ll give that a try… Thank you @Paul_Oliver

1 Like

The Z-Wave Switch and Child Mc driver works for on/off, but still no control for the switch led.

Try @Mariano_Colmenarejo ’ Z-Wave Device Config Mc" driver to change the parameters.

Description: For Z-Wave Devices: Show Fingerprints, End points Command Class and Allows you to view and configure Parameters and Group Association

I have never used this but I believe you temporarily change the driver to this one, change the parameters then switch back to the original driver.