Meross Devices and New ST APP Linked Services

This might be useful for anyone who as purchased any Meross devices and experienced problems with the integration into new ST app.

I purchased 3 Meross outlet plugs which are very large in form factor to replace SmartLife outlets as they discontinued their IFTTT account so no longer worked via ST once the new ST skill killed the use of Alexa routines.

Meross works well but I found the integration with the new ST app via linked services really poor requiring you to authorise every day or so. I reported to ST support and they said they knew about it but didn’t offer any fix date and I’ve heard nothing since

So a few weeks later I contacted Meross who were more responsive and said they had already fix this … shame ST support didn’t tell me this… sorry does ST support still exist ?

So the fix is quick and this is the way it worked for me.

From ST app home screen click on the 3 lines top left and then click the setting cog top right.
Select link services and delete the old Meross entry by swiping left. (assumes you had already installed the Meross services called Meross , new one is named differently)

Exit back to home screen , click on the + (top right) , select device and in all brands scroll down to Meross. Select outlet and click on Meross, you will then be prompted to authorise by logging in to Meross. Once done it will create the new linked service which should be listed as meross-c2c-pro if you use Alexa it will update Alexa as well.

This worked very well for me and solved the constant need to re authorise and now the Meross devices status are correctly displayed in the new ST app.

Hope this helps anyone with Meross devices who as experience the problems with the linked services.


Strange that you didn’t receive the email that Meross sent out in August or was it a notice in their app, I forget which one. The email announced the new integration and outlined the steps you noted above :frowning:

Nope didn’t see that and I’ve checked back in my deleted to make sure I didn’t miss it …

But shame ST support couldn’t close the loop on a call and email as they must have known .

1 Like