Matter Tuya wifi smart switch?

Tried to look around but am not successful. I got one of these below and I was able to detect in SmartThings and add. But the switch doesn’t show me on/off switch in SmartThings or anything. Just says connected. I thought it’s just a matter of having the right channel driver installed.

Anyone know which channel/driver is need for the 1ch and 2ch switch?


The correct driver would be Matter Switch which it should have picked up during pairing.

Did you pair it by scanning the QR code?

1 Like

I have this one and it paired well with the Matter switch driver using the QR code. The messages during pairing came as though being paired to Homekit (I don’t have a hub) but in the end all correct in Smartthings.
I had tried pairing to Alexa/Eero but it didn’t want to share so deleted and directly to ST. For my first Matter device (apart from Hue bridge) I’m quite impressed with it.


Hi All,

I just launched ST and it automatically said it found a UA-Swirch. It asked me to scan QR code, the select wifi network. It got added.

It does say Matter Switch under driver but I don’t see an on/off button, shouldn’t I see one?


I would delete it and start over to see if it works better. It may help if you pair it next to your hub.

This is what I see

Nope. Deleted and re-added. I still see:(

Any other ideas?

@Johnnybegoode Is this the same driver settings you have?

No. I hadn’t even looked here but both Device Name and Profile are switch-binary
The rest, including manufacturer’s name and code are the same.

So I prob need to find Swich-binary driver.


Can’t figure it out. If anyone in the community can help? Don’t understand why it works for some but not me… unless switch is really different hardware?


I don’t think we are given the option to change drivers for a matter device. While it appears similar in the app to other protocols like in Zigbee, it’s a different process.

What model hub do you have and what firmware level is it?

Yup :slight_smile: I just found out I can’t change driver :slight_smile:

I have v2_hub version 000.050.00010.

I just noticed it’s using the driver in “SmartThings Drivers (Beta)” channel. Maybe that is the difference? Maybe I should remove the beta channel? Or is this common?


The beta driver is usually more up to date than the stock driver, but could have bugs.

If you remove your device and the beta driver, the next time you add the device it should pick up the stock driver.

1 Like

Hmmm. Removing the beta channel will be tough. lot’s of devices using it. I didn’t have the matter switch installed from the channel with the first one anyways, but it still seemed to have used it. I assume I would have to remove the entire channel and for that I would have to re-do a lot of my devices currently using the beta.

I had another similar switch but it was 2ch instead of 1ch, it added, I can see the buttons and seems I can send an on command but then it hangs and tells me there ie a communication error. so I can see buttons but dtill doesnt’ work well.

IF anyone has matter expertese to debug I can provide logs or follow any instructions.


Don’t remove the beta channel. Just the beta Matter Switch Driver.

Issue 1: Unfortunately, that didn’t work or change anything. Still exact same behavior where the Matter Switch comes up as matter-thing and no buttons shows up.

Issue 2: I tried another matter switch but it’s 2channel. Looks similar. It adds up as matter-switch and two buttons, from advanced web GUI I can send on/off commends and it works. But it looks like the button attributes is not getting updated… so I don’t get the status of buttons updated and app hangs

Help :slight_smile: those switches are nice if I can get them to work.

For what it’s worth I have the Matter Switch driver from the Alpha channel. I installed it myself before I made the first try with Matter, which was my Hue hub.
Went perfect, as did then this switch. I was surprised how easily it all went so I can’t imagine what is causing your problem.
Best of luck.

1 Like

Guys, is it worth reposting at the dev thread? Seems like maybe needs driver tweak…

I don’t want to give up on it :slight_smile:

The first step would just be to report it by creating an official support ticket and see what they say.

The first person you get will probably just be a general Samsung employee working off a script and won’t know much, but if you persevere, the ticket will get escalated to a smartthings engineer who is working on matter.

Use the email or phone options:

( the dev thread is more for people who are writing their own edge drivers or device manufacturers.)

1 Like