Matter pairing interrupted (Jan 2024)

Hi, I was going through the process of adding a device ( a tp link smart outlet) to smartthings but it did not complete. I could see it got added to the iCloud Keychain but I don’t see an option to generate a new code there. When I try smartthings again with the sticker code it’s asking to ‘prepare the device’ using the device user guide, and I am stuck at this point. Is there a way to reset the pairing?

I read somewhere the code can only be used once, so I’m wondering if I should I delete it from the apple keychain and try again?

I tried to see if I could added to the Home app in ios, but it complains I need a hub (and I don’t have any of the apple devices that would work as a hub) .

The ios app has been broken for Matter devices the past several weeks for me. Do you have any Alexa or Google smart speakers you could try with?

1 Like

I have been able to reuse the code after factory resetting devices.

2 Likes

Unplug the device, then plug it in and do a factory reset.

1 Like

Thanks everyone, I was managed to set them up after doing a factory reset, but only after setting them up first using the TP-LINK Kasa app (I was testing if I could avoid it since it’s a “matter” device).

I’m not sure 100% necessary, but one plug was giving me trouble and I went and remove it from the icloud keychain (in the iphone one goes to Settings → General → Matter Accesories

I tried and they seem to be working even without internet (i.e. using local control), but for some reason I keep getting a “new device” found in the smartthings apps, and the icloud key chain does not list them associated with smart things (as it does for some other tp-link dimmer switches I have), so I might not be totally out of the woods yet.

edit: just as I hit save the devices are now showing as associated with the smartthings hub in the iphone, odd!

I had this same experience with an XFOX/Tuya branded Matter device, it took 3 tries. One failed attempt as described above, I got the “Prepare the device” message and was stuck there. I then figured out how to factory reset it by holding power 10 seconds (not from doc) and it partially added it to Smartthings–it added to ST but said not all details were available yet and it never accepted on/off commands. On the third try this is what worked:

  1. I factory reset the plug
  2. Smartthings asked me if I wanted to add it (I did not specifically add)
  3. Smartthings offered to scan the code, scanned it, and added to iCloud.
  4. Smartthings added the device.