Marketplace is empty (UK hub with US location)

Hello to all of you. I am new to smartthings.
I installed the mobile App to my Samsung S7 phone but when I go to the marketplace tab I do not see anything. I tried uninstalling the app and reinstalling it but nothing changed. I also tried to my wife’s Honor 8 phone but I get the same problem.
Also when I go to Automation / smartapps / and press the “Add a smartApp” button the application closes.
I am in Greece and during the installation I had choose that my location is in US. (Can I change it now to Ireland? Greece is not a choice).

I am in this exact same situation. I get nothing for SmartApps or Marketplace.

I selected US as Sweden was not an option.

Are you guys using US or UK hubs?
You need to register it depending where the hub is for. For UK you can read anywhere in Europe.
When you go to marketplace, you should then go to Smartapps, scroll down and select My Apps.
Is this what you guys did?


Mine is a UK hub but I selected US during install phase.

I have exactly this problem also

Thanks Bobbie. How do you change the region? Do you need to do a factory reset?

You want to start again and register it as a UK one. I don’t know if it is important or not but the two regions use different frequencies for Z-Wave so it may affect any upgrades if it thinks its in the wrong region. Can’t say for sure though.

Personally I think I would start again, especially as you have nothing on it yet.
Best to get things straight to start with.


Mine is also a UK hub.
I won’t have time till the weekend to make a reset so if anyone else do it please inform us for the outcome.

It may be OK to leave it as a US hub. I just don’t know. Support will know if it will cause an issue.
Just saying what I would do. Sorry if this is causing any stress/issues. :zipper_mouth_face:

I suspected that the region may be the problem and that is why I mentioned it in my first post.

Hi all. I reset the hub and set it to UK region instead and now everything works. Thanks for your help!


Cool :slight_smile:
I have exactly the same situation and work on NA04 server.

I wrote to support over the weekend but no reply yet so I will try and reset - it is a back to factory reset you have done right ?

One more question… can you reuse your user name or do you have to make a new ?

I just deleted the ‘home’ location with the app then did a hardware reset on the hub. Press and hold the reset button on the back for around 30 seconds until the light is yellow. You can reuse your existing account. It is the hub that needs resetting not your account.

Did you had to uninstall the app from your mobile phone?

No I didnt do anything on the phone. Everything just worked after the hardware reset.

Thank you everyone :slight_smile:

Today I also did a hardware reset to my Hub. When I opened my phone app it asked me again to choose the region. This time I chose UK and everything is working as it should. The only thing is that I had to pair all of my bulbs again.

1 Like

I’ve the same problem and I solved creating another Location with UK as the country.
No need to reset the HUB! :slight_smile: