Making sure Smartthings motion sensors, are running locally, and not on the cloud (Smartthings V2 Hub)

Hello, I am a UK user with a Version 2 Smartthings hub. I have just recently noticed that all 9 of my Smartthings V2 motion sensors were not showing locally on my hub, but were running over the cloud.

They were set to “SmartSense Motion Sensor” by default in the IDE.
I changed the motion sensors device type to “SmartSense Motion/Temp sensor” and now my motion sensors show up to be running locally.

I had a lot of problems with my motion sensors intermittently triggering over the last week, and they have all been perfect since I have changed over to the locally run device type.

It is strange why they all defaulted to the cloud device type, when running “connect new device”, instead of the local device type.

This check may help those that also have Smartthings V2 motion sensor, problems!

Local run devices check for V2 Hub:-

Uk Customers

US Customers


I’ve noticed that about some of my smartapps and devices here in the US. I’ve had smart Lighting apps not show up running local with locally running devices. I would just go in the rule and change the device to a different one, then change it back… then it would just show up.

Hello Bamarayne, I take it you have V2 Smartthings motion sensors! If so, did they also default to “SmartSense Motion Sensor” in the IDE, Instead of “SmartSense Motion/Temp sensor”?

It has been 3 days now since I manually changed the motion sensors to run off the smartsence motion/Temp sensor device type, and they are running perfectly!

Hopefully ST will allow more apps/devices to run locally, as cloud based items have just been too unreliable!

I just checked mine, and they were all running local using SmartSense Motion Sensor. Curious as to why the same device type runs differently (local vs cloud).


Very strange indeed! I have tried many times, and could only get them to run locally using only the “SmartSense Motion/Temp sensor” device type!

I am really happy now, but wanted others to be aware that they may need to check, as I had presumed the motion sensors were all running locally for many months, until I had checked, and realised the motion sensors were defaulting to a device type that was not allowing them to be locally controlled.

I tried all nine of my ST VER2 motion sensors independently, and each one gave the same results!

I was wondering Bago, if you are a (US) user or (UK) user? I am just trying to rule out if it is something different that is happening on the (UK) ver2 hubs!

US user…

Very strange indeed. Maybe give support a shout just in case you U.K users don’t have local process for that device type for strange reason and hopefully they can fix it.

Actually the only thing I own that is smartthings is the hub. I’m using Enerwave ceiling mounted motion sensors. I have four of them using the stock Zwave Motion sensor device handler.

If you can get acceptable use from a device while using a stock ST device handler then you can get them to run locally…

Ok thanks guys! I will send a message to support to make them aware, just in case it is affecting others here in the (UK)

I tried that dh with my Enerwave sensors and they wouldn’t even work… They work great with the stock Zwave dh so in sticking with that.

Where do you check in the IDE to see if they are running local or not?

1 Like

cool…and thanks. How do I get to this list from IDE menu?

Not sure. I saved the link as a bookmark.

Here’s the one for local apps:

Really? I hate undocumented features!!!:grimacing:

Thanks for the info. I guess I will bookmark them also.

I have the 2 different links up on post #1.

Apparently there is one link for the (US) users and another for (UK) users!

(UK) users, clicking on the (US) link, will show up as no locally running devices!

The correct link must be used to show the correct status of locally running devices!

UK v.2.0 hub as well. Just tried what you propose and both my motion sensors are now listed under local devices.

Thanks a lot!

No problem ktsi,

were your motion sensors originally set to “SmartSense Motion Sensor” by default in the IDE?

Did changing the setting to “SmartSense Motion/Temp sensor” allow the motion sensors run locally?

Yes and yes. And i hate the 20 char limit.